Viper Plasma
Login to Your Account
Results 1 to 2 of 2

Thread: Viper Plasma

  1. #1
    Join Date
    Dec 2011
    Las Vegas
    Post Thanks / Like
    Likes (Given)
    Likes (Received)

    Default Viper Plasma

    Hello All,

    First thank you for anybody that can give me any help!

    I just bought a plasma table from a friend of mine that ordered it a few years ago and never put it together. Now, I am trying to get it up and running, but it turns out that Viper plasma went out of buisness. There was no documentation with the table and I am at a loss. The table is for a half sheet, and I have the Proma THC, and a Hypertherm 105 power supply. Problem is I just dont know how to hook any of it up! I did get the mach 3 software licensed and have been able to move the x and y axis jogging around. But I think I hooked the proma up incorrectly and may have burned out the z axis stepper motor as the first time I put the proma in "test mode" and it tried to move the Z it alarmed the Geckodrive G540 out, and now if the z motor is plugged in, the G540 will not come out of fault. I ordered a new stepper motor today. Also it will go into fault if I jog it around, and then press go to 0 and it tries to move very quickly.... Does anybody else have one of these systems from Viper or even not from Viper that could help me get this hooked up correctly?

    Please Help me!

    I have attached a couple pics of the table and electronics.

    Thanks again!g540-connections.jpghypertherm-105.jpgplasma-table.jpgproma-thc.jpg

  2. #2
    Join Date
    Mar 2018
    Post Thanks / Like
    Likes (Given)
    Likes (Received)


    I hope you have worked out all the bugs. I see you had to replace a stepper motor because one of my steppers froze up and the number on the motor will not cross over to any steppers on the market. hope if you could help out


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts