Adding EIA to T2 mazatrol
Largest Manufacturing Technology
Community On The Web
Close
Login to Your Account

Page 1 of 4 123 ... LastLast
Results 1 to 20 of 79
  1. #1
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default Adding EIA to T2 mazatrol

    Hi,

    I know this has been discussed before and some of you have tried to add EIA to your mazatrol and it hasn't worked but I'm a bit thick and would like to have a crack at getting it working.

    Does anyone have a fx784-9 or preferrably a FX884 board with the EIA eproms to suit a T2?

    I have a FX17 board ready to go in.

    My plan is to get the needed EIA chips and copy them so if anyone in the future wants to add it they can.

    With Fusion360 now having lathe posts it would be a great thing to post out to the lathe instead of using mazatrol. Don't get me wrong mazatrol is great but I need to spend a lot more time using it to become proficient.

  2. #2
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    I have a QT10N T2 with the EIA feature.
    But I am not sure how I can help you...

  3. #3
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by benganboll View Post
    I have a QT10N T2 with the EIA feature.
    But I am not sure how I can help you...
    Well if you could copy the eproms using a reader then we could burn new ones.
    Here's a write up on how to do it.
    http://www.classic-computers.org.nz/...-21-eproms.htm

    Do you post from a cam package to your lathe?

  4. #4
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    My T2 is in Swedish, is that in the same roms?

  5. #5
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by benganboll View Post
    My T2 is in Swedish, is that in the same roms?
    Yes, I think so. The language chips are separate.

    Here's Dave from EEVblogs discussing a EPROM reader and burner.
    EEVblog #411 - MiniPro TL866 Universal Programmer Review - YouTube

    I'm happy to pay for a eprom reader to be sent to you if are keen to try and read your ones.

  6. #6
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    I will check what board I have in my machine...

  7. #7
    Join Date
    Apr 2014
    Country
    AUSTRALIA
    Posts
    358
    Post Thanks / Like
    Likes (Given)
    157
    Likes (Received)
    112

    Default

    Any movement on this?

    Sent from my LG-H815 using Tapatalk

  8. #8
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by xa-mont View Post
    Any movement on this?
    I haven't heard anything back.

  9. #9
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by benganboll View Post
    I will check what board I have in my machine...
    Hi Benganboll,

    You're about the only person I've come across that has a T2 with EIA. Is there any chance you could just take a photo of the FX784-9 board showing the EPROM's so I know for sure what I need to have?

    I might have a lead on a T3 FX784-9 board that I think should work as I think the extra axis can be disabled in the parameters. (I could well be wrong though).

  10. #10
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    Sure I can do that.
    buy me an eprom reader/writer and I will read them.

  11. Likes GP Tech, xa-mont liked this post
  12. #11
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by benganboll View Post
    Sure I can do that.
    buy me an eprom reader/writer and I will read them.
    You're a legend, pm me your address and I'll sort something out.

  13. Likes xa-mont liked this post
  14. #12
    Join Date
    Dec 2012
    Location
    Great Britain
    Posts
    56
    Post Thanks / Like
    Likes (Given)
    1
    Likes (Received)
    44

    Default

    If you need or want any other help, I have a Mazak QT20N with a T2 controller and eia option on it. Can this method be used on any of the newer controls as we have T32's and 640's without eia?

  15. Likes GP Tech liked this post
  16. #13
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by will_0000 View Post
    If you need or want any other help, I have a Mazak QT20N with a T2 controller and eia option on it. Can this method be used on any of the newer controls as we have T32's and 640's without eia?
    No, this will only work (if it works) with the matching controller.

  17. #14
    Join Date
    Apr 2014
    Country
    AUSTRALIA
    Posts
    358
    Post Thanks / Like
    Likes (Given)
    157
    Likes (Received)
    112

    Default

    Quote Originally Posted by benganboll View Post
    Sure I can do that.
    buy me an eprom reader/writer and I will read them.
    That's the Christmas spirit.

    Sent from my LG-H815 using Tapatalk

  18. Likes cwtoyota liked this post
  19. #15
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    So what is yout theory, just adding the EIA chips?
    My ST30ATC M/C T3 1988 has a FX-884 instead of FX784-8 and FX784-9.
    Is that a newer version?

    These picture are from my QT10N T2 1986
    fx784-9.jpgfx784-9b.jpg

  20. Likes GP Tech, cwtoyota liked this post
  21. #16
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by benganboll View Post
    So what is yout theory, just adding the EIA chips?
    My ST30ATC M/C T3 1988 has a FX-884 instead of FX784-8 and FX784-9.
    Is that a newer version?

    These picture are from my QT10N T2 1986
    fx784-9.jpgfx784-9b.jpg
    Yes, the FX884 was a later board and replaced both the FX784 boards. Could you take a picture of the FX884 board as well?

  22. #17
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    Pictures from a FX884 (1988 T3)
    fx884a.jpgfx884b.jpg

  23. Likes GP Tech, cwtoyota liked this post
  24. #18
    Join Date
    Apr 2013
    Location
    South Australia
    Posts
    219
    Post Thanks / Like
    Likes (Given)
    63
    Likes (Received)
    90

    Default

    Quote Originally Posted by GP Tech View Post
    Hi Benganboll,

    You're about the only person I've come across that has a T2 with EIA. Is there any chance you could just take a photo of the FX784-9 board showing the EPROM's so I know for sure what I need to have?

    I might have a lead on a T3 FX784-9 board that I think should work as I think the extra axis can be disabled in the parameters. (I could well be wrong though).
    The T3 board has to be the same software version as yours for it to work

  25. #19
    Join Date
    Jan 2015
    Country
    AUSTRALIA
    Posts
    316
    Post Thanks / Like
    Likes (Given)
    223
    Likes (Received)
    93

    Default

    Quote Originally Posted by sudsy55 View Post
    The T3 board has to be the same software version as yours for it to work
    From what I can tell all the software is on the FX784-9 board.

  26. #20
    Join Date
    Feb 2015
    Country
    SWEDEN
    Posts
    312
    Post Thanks / Like
    Likes (Given)
    60
    Likes (Received)
    165

    Default

    The EIA/ISO eprom chips on the FX784-9 in my T2 are 6pcs of 27128 (128kbit=16KB)
    And on the FX884 in my T3 there is 4pcs of 27256 (265kbit=32KB)

    So I think your best chances are the FX784-9 chips.
    Do you have the FX784-8 + FX784-9 or FX884 the your machine and what software version do you have?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •