Program "Freezes" at tool change (if selected tool is already in spindle)
Largest Manufacturing Technology
Community On The Web
Close
Login to Your Account

Results 1 to 5 of 5
  1. #1
    Join Date
    May 2013
    Location
    Perrysburg, OH
    Posts
    24
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Question Program "Freezes" at tool change (if selected tool is already in spindle)

    Forgive me if this question has been addressed. This is my first post and I'm anxious to get to an answer, and my basic search didn't turn up anything relating to my machine. Here's the specs:

    Toyoda FV 45
    Fanuc 11M Controller
    21 Slot Rotary Tool Magazine (Numbered 0-20)

    The issue I'm having is this: if I have a tool in the spindle (let's say tool 5) from a previous program (or from some MDI work prior to a program) and I load/DNC a program with that same tool, the machine will get to the tool change and just plain stop. Here's an example:

    G91 G30 Z0
    X0 Y0
    T05
    M06
    G90 Z3.0
    G1...

    If start with any other tool in the spindle, the program would work perfectly, but if I had started with Tool 5 in the spindle, the machine gets to ">T05" and literally........ stops. No error, no message, and no way to continue.
    At a minimum, I would like some kind of error... But I would prefer (as you can imagine) that the control recognizes that the selected tool is already in the spindle and continues with the program. I am assuming that there is a parameter somewhere that can be changed to accommodate this, but I can't find it in any manual. Thanks for your help!

  2. #2
    Join Date
    Mar 2011
    Location
    MASS
    Posts
    696
    Post Thanks / Like
    Likes (Given)
    307
    Likes (Received)
    246

    Default

    Are you turning the machine off at any point?
    If so, you may have to send the tool back to the magazine. T0 M6

    On my older matsuura I would have to send the tool back to the magazine with G46 so the control knows that upon start up the spindle is at tool #0

    Also try T05 M06 on the same line.

  3. #3
    Join Date
    Apr 2013
    Location
    Oregon
    Posts
    188
    Post Thanks / Like
    Likes (Given)
    202
    Likes (Received)
    144

    Default Program "Freezes" at tool change (if selected tool is already in spindle)

    This is most likely caused by having T5 in the program while T5 is in the spindle. You can't call up the same tool that is the same as the one in the spindle.

  4. #4
    Join Date
    May 2013
    Location
    Perrysburg, OH
    Posts
    24
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default I know!

    Quote Originally Posted by Moriboy View Post
    This is most likely caused by having T5 in the program while T5 is in the spindle. You can't call up the same tool that is the same as the one in the spindle.
    That's EXACTLY what it's caused by. I thought that was pretty clear. I'm looking for a way to get the machine to keep running if T5 in the program while T5 is in the spindle.

    Anyone have any ideas?

  5. #5
    Join Date
    Apr 2013
    Location
    Oregon
    Posts
    188
    Post Thanks / Like
    Likes (Given)
    202
    Likes (Received)
    144

    Default Program "Freezes" at tool change (if selected tool is already in spindle)

    The only way around it as far as I know is to put T5 on its own block in the program and put a /(block delete) in front of it and turn on the block delete function.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •