What's new
What's new

93 Mazak VTC-41 with Yasnac control won't home axis, won't move at all

Joined
Jul 25, 2022
I have a Mazak that won't move at all, no matter what I do, no matter what settings or buttons I've pressed. I'm sure my servos are on. I can request the spindle to rotate and that works fine, both directions, any speed I ask for.
My Mazak is 1993 VTC-41 with the Mazatrol EIA Yasnac mx3 control. This machine is new to me so I don't know the standard start up procedures.
I have learned about the DIAG screen showing the 0's and 1's and I'm betting that this machine is simply waiting for a door position switch or an air pressure switch to indicate a 1 before it will let it move. Since I have chased the air pressure and tried things like reversing the phasing and doors closed, and I have verified that each button changes a 0 to a 1. My new goal is to compare my first 3 DIAG screens with someone else's Mazak in order to learn what is different.
Either that or maybe someone can offer a suggestion that I haven't thought of yet.
NOTES: The machine says LSK and RDY in the lower right hand corner. The LSK changes to F when I set MDI and ask it to feed and it changes to an R when I ask it to G91G0 any axis any direction. but it will just sit there, showing the F or R, yet not feeding or rappiding.
If I grab the X ballscrew and twist it by hand, the motor will kick in and force it back to the position it was in before I touched it. This proves to me that the servos are on and the machine is supplying power to my axis motors.
Any Suggestions? Does anyone else have this control who might be able to compare DIAG screens? I would appreciate any help at all!
Alarm517.jpgDIAG1.jpgDIAG2.jpgDIAG3.jpg
 
It doesn't move with the handle. I've tried a thousand combinations of toggle switch positions, key positions, button holding vs. button pressing, button pairs, button pairs with handle in every mode, every speed, every increment, every direction.
I've come to the conclusion that this problem is not a panel / button pressing problem. Every button, toggle, key and dial changes a 0 to a 1 on one of the first 3 DIAG screens.
So from this point, I have to assume that the control doesn't believe that it is safe to move the machine. I've got the feeling that it is waiting for a safety switch to tell it to allow movement. If not a safety switch then maybe a pressure switch or a limit switch.
Not knowing what it may be waiting for, my next course of action is to see if someone else's machine has a 1 where my machine shows a 0, then try to identify what kind of signal is reporting closed and see if I can get my machine to report that same signal and hopefully, fix the failure.
I did contact Mazak about this. They put me in touch with a guy who knows Yasnac and the electronics in the cabinet but he was not proficient with my particular machine. He had me try many things but the 1 thing he kept saying was "Are you sure that you have the correct air pressure to all parts of the machine?"
So I replaced several air hoses and I even took apart and rebuilt an air valve that was leaking. After that, I disconnected and reconnected the air while watching the DIAG screens and I found that #1013 position 7 changes from a 0 without air and to a 1 with air pressure.
What might be throwing me off is that maybe a second switch is supposed to be changing from a 0 to a 1. But if not, then it is not likely that air pressure is my failure.
 
P.S. The 3rd pic above shows #1013 position 7 as a 0 but that's just because at the moment I took the picture, I had forgotten to connect the air back up. But right now, the air is connected and #1013, 7 shows a 1.
 
if you cant move one axis or all of them, and there is no alarm on the screen, it is going to be an INTERLOCK signals that isnt ON, or FEED speed is ZERO, or M/C locked, or something wrong with PLC.

Lets go through a list of NC -PLC interface and check what it is that it wants,
#1300- 1305
#1319-1322
and
#1284-1294

Anyway. Select ZERO Return mode, select axis, press direction and take pictures of these interface signals. That is all you can do to try to understand why nothing moves.
 

Attachments

  • 1.pdf
    2.8 MB · Views: 11
  • 2221.jpg
    2221.jpg
    115.2 KB · Views: 7
Last edited:
It appears that #1300 directly correlates to my mode selector switch. Each position moves the 1 to the next ascending bit.
#1301 is altered by the rapid override and feed rate override knobs.
Under your conditions... #1302,0 is altered by X+ and it won't change to a 1 until I've pressed X-. Pressing X- changes #1302,1 to a 1 for one second then that bit becomes unresponsive. Once I've pressed X-, then X+ begins to change #1302,0 to a 1 during the time that I am holding it down.
Similar conditions exist for Y between #1302,2 and #1302,3 and Z does the same thing to #1302,4 and #1302,5
#1303 bits 5,6,7 are altered by turning the spindle speed override knob. Bits 1-4 don't change no matter what I press.
#1304 bits 4,5 are altered by the increment selector toggle and the rest of the bits remain 0s
#1305 - Each bit is altered by toggles like single block, block delete, dry run, etc. each toggle does affect a bit with the exception of Override Cancel, which doesn't change any bit on any screen from 1260s to 1360s.
NOTE: The axis selector switch doesn't effect any bit on the #1300 screen
#1319 Every bit shows a 1 and nothing I do changes that
#1320 bit 2 changes to a 1 when the mode selector is in any of the automatic modes and remains a 0 when in any of the manual modes. the rest of the bits remain 0s
#1321 Every bit is showing a 1 and nothing I do changes that.
#1322 Bits 0,1,2,4 show a 1 and bits 3,5,6,7 show a 0 and nothing I do changes any of them
#1284 through 1294 has no changes no matter what buttons, toggles, keys or knobs are changed with one exception
#1287 is related to spindle encoder feedback. It doesn't matter if I spin the spindle by hand or request the machine to rotate it, bits 0 and 1 will fluctuate very quickly.
#1288, 89, and 90 bits 4 and 5 fluctuate rapidly all the time. Again, I think these bits might be encoder position feedback for X, Y, and Z motors.
The handle dial changes all the bits of #1277 as it is turned
So far, I haven't found which bits are altered by 2 of my controls - Override Cancel and Axis selector
 
I managed to get the Override Cancel toggle to alter #1301,7 It has no effect until I switch the mode selector to Tape.
Something similar happens with the Axis select toggle. It will only alter bits when in Handle mode.
 
I printed out the data bit chart that you posted, Thank You so much for that!
I will go bit by bit, line by line, testing to see if I can alter each bit and noting what conditions allow for that bit to change.
With diligence, I hope to identify something non-responsive.
This may take several days to complete since I still need to earn a living outside of doing this.
Again, thank you for the charts! I will post again once I have completed the list or once I have found the solution.
 
I have a question for you... Is it possible to force a bit to change as a test?
For example #1301 bits 5,6 and #1314 bits 4,5 are both Rapid Traverse Rate Override yet #1314 are both 0s. That's what #1301 reads when I turn the knob to 0 percent.
Is it possible to change #1314 to match #1301 just to test? Maybe the machine thinks my knob is turned to 0 percent rapid speed. That could keep me from homing or moving my machine, possibly???
 
Ohh.. Jesus, hard to understand this. Would be nice if you take some pictures and post them here? I ll see if I can read them anyway.


->Select ZERO Return mode, select axis, press direction and take pictures of these interface signals in exactly the moment you are pushing DIRECTION to move axis.

I dont think you can force these diagnostic signals, they are just status of inner machine logic.

I think at this moment you have to go through DETAILS OF SIGNALS, all of them, and see what the manufacturer says about them. No need to test anything, try combinations or whatever. Say, you just focus on ZERO RETURN, attached picture.

Signals to be worried:
-FEEDHOLD and STOP arent active.

- JOG (MANUAL FEED) mode is selected
( When the JOG input contact is closed, and other
mode input contacts are opened, the control enters
the manual jog mode, and the machine is jogged
in the respective directions in response to the
input of +X , -X, +Y , -Y, +Z, -Z )

- When the control is an the manual jog mode and
this input is closed, feeding in the manual feeding direction is performed in the
"RAPID FEED SPEED"

-Manual feed axis "direction" selection signals.

-MANUAL JOG FEED RATE SELECTION ( JV1-JV16)
These inputs specify the manual jog feedrates in the manual JOG mode.

-ZRN signal, DEC-deceleration signals ( I assume these DOG switches) , ZP-signals when machine is at ZERO position. Make sure non of axis is pushing END OF STROCK limit switch.

-MRD- machine ready signal

-No EXTERNAL RESET is active

-No M-code request is active ( TF, SF, MF)

-SERVO OFF SIGNALS (SVOFX....), makes sure servo axises are ready and energized.

-All sorts of stroke limit switches arent active.

-SKIP input isnt active

-And of cause AXIS INTERLOCK SIGNALS ( ITX, ITY...)
When axis interlock contact is opened during
motion, the axis is decelerated to stop. Closing
the interlock will resume the remaining operation
interrupted by opening the interlock contact.
When the remaining operation is completed, operation will advance to the next block.
 

Attachments

  • 32.jpg
    32.jpg
    173.3 KB · Views: 5
  • 2.pdf
    1.9 MB · Views: 6
Last edited:
Hi lads,
I've just recently purchased this same machine and during the move, x and y axis moved and now I'm experiencing the same problems as you've noted earlier Frederick, Z axis is fine as it was set onto a block of timber to share the load. I've spent a few hours going through parameters as per the supplied PDF's in an earlier post thanks to NoName777 to familiar myself with this machine as I'm yet to be supplied the manuals, erverything looks good but not happy as to the axis's moving whilst powered down. I'd like to think it would be as simple as modifying a parameter/s that will allow the axis to move and reteach home.
 
Tropical Coast... You should be able to move your X axis by hand while your machine is powered down by reaching in the back and twisting the ball screw with your hands. You may have to remove a convoluting cover. Y may be reachable also. If your machine is sitting against it's limit then just move X and Y off the limits and retry.
 








 
Back
Top