What's new
What's new

Another Prototrak SLX 5654 error


Feb 5, 2016
We’ve got a very low hours SLX that the company purchased new about a decade ago, and I’ve been running it off and on for about a year and a half now (prior to that was only used a half dozen times) and it was working perfectly yesterday for almost 8 hours straight, I followed my usual shut down procedure, home position, save program, save tools, then SYS, SHUT DOWN, wait 2-3 minutes for Windows to do Windows things, then ‘safe to power off’ message, etc. came in this morning, flicked it on like I’ve done 50 times before, did the usual start up procedure, set max rpm, set home position, set tool group to indexer, activated indexer via serv code, set current position (same as home position as I home the machine before shutting down) went into ‘tool path’ to verify program was still correct, and got hit with ‘warning 5654 data error at event #3 cannot apply tool compensation on event data check and edit event data’ so, I went ahead and erased the program, rewrote it start to finish one step at a time, and still got the same error, reset all (3) of my tools, still get the error, decided to try shutting down and flipping the main breaker off for 5 minutes, thinking maybe it would reset, back on, still get the error. I’ve tried editing portions of the program, just changing a couple values here and there, etc, the tool table is just full of zeroes as we only do short runs of parts, no need to mess with the comps/offsets when I’m changing tools out and resetting them for each and every job anyway. I saw another thread with a similar issue, but was in regard to using drills mounted in the indexer, which I have done before without issue, but no drills are in currently, and none of the tools currently listed in the offset page are drills, so I don’t believe my problem is related to that. Beginning to get frustrated. Another 35 minutes before the engineers show up to start their day, I’ll have them call up prototrak, but from reading other peoples’ posts, I won’t hold my breath for them to be of any usefulness, since it’s basically an antique in their mind it sounds like, maybe we will have better luck, being the original purchaser of the machine, and with under 1000 hours of run time… but again, I won’t be holding my breath. Just wondering if anybody here knows of a serv code or a way to reset to a previous software backup perhaps?
Ok. Solved the issue. Turns out I’m an idiot. Sort of. I forgot that last thing yesterday I changed the ‘finish cut’ on the turning cycle, at the behest of a senior coworker, to .003” (previously had it at .001”) and when I remembered (right after posting my thread) I changed it back to .001” and now it works fine. But why, even when I completely remade the program would it not allow a larger finish cut than .001”? (Tried .002, .0015, .005, all of which cause the error to return, but .001 works…)
Can you share the program somehow? I use their controls a fair bit, I might be able to offer some help