What's new
What's new

ATC macro won't run leadwell tdc-450 meldas 310m, loaded manually, "p232 no program no" error, p460 tape/Io error after deleting m6

madko

Plastic
Joined
Apr 28, 2023
I'm playing with a leadwell tdc-450. I've gotten it to run, test cut, and move the atc only with the atc ori button. I was getting z51 and e51 errors in mdi, but I went through the FORMAT and load fixed cycles procedure here. https://en.industryarena.com/forum/mitsubishi-m-60v-meldas-330m-m01-error--137540.html

This cleared the error, but it comes back, so I'm suspecting battery issues or something else. New battery on the way.

I have the machine Params and I reloaded the fixed cycles.

When I go to macros, I see something for M6 that should load program 9001. I manually entered the atc macro as in the electrical manual to memory in 9001, I can see it, but when I try sending M6 t1 via the rs232, I get no program no. As if it can't start the atc macro. If I delete the M6 t1 from the sample program I have, it moved around and seems fine, but it does give a "p460 tape I/o error" after. Not sure of that cause yet, but figured I'd mention it. 1000006957.jpg
1000006954.jpg
How do I get the program to run when M6 TX is called, or am I missing something? I've been flipping through the generic meldas 300 manual, and the electrical manual.

Issues:

-9001 program won't get called and M6 results in error p232 no program no

-p460 tape I/o error after sending rs232 program with M6 deleted, but it does move before throwing it. Sending via NCLink and 1ms line delay. I saw this comment for a meldas 520 elsewhere, so I may increase the delay "use an 2ms linesend delay and that seems to allow the buffer to stay happy but In case of the error you had before you might have to increase this delay. It's a bit of trial / error to fine tune your particular set-up."

-e51 file open error in mdi, cleared by format and reload fixed cycles, comes back. Replacing battery.

Program I tried sending:

%
O2000 (T)
(DATE - 20/06/2023)
(TIME - 00:19)
(T1 - 1/2 FLAT ENDMILL )
(T2 - 1/8 DRILL )
(T3 - 1/2 FLAT ENDMILL )
(OVERALL MAX - Z.25)
(OVERALL MIN - Z-.5)
G00 G17 G40 G80 ( 1/2 FLAT ENDMILL)
M06 t1
(MAX - Z.25)
(MIN - Z0.)
G00 G17 G90 G54 X2.75 Y2. S400 M03
G43 H1 Z.25
Z.2
G01 Z0. F5.
X-2.25 F15.
G03 X-1.75 Y-1.5 I0. J.5
G01 Y1.5
G03 X-2.25 Y2. I-.5 J0.
G01 X-2.75
Z.2 F25.
G00 Z.25
X-2. Y2.75
Z.2
G01 Z0. F5.
Y2.25 F15.
G03 X-1.5 Y1.75 I.5 J0.
G01 X1.5
G03 X2. Y2.25 I0. J.5
G01 Y2.75
Z.2 F25.
G00 Z.25
X2.75 Y2.
Z.2
G01 Z0. F5.
X2.25 F15.
G03 X1.75 Y1.5 I0. J-.5
G01 Y-1.5
G03 X2.25 Y-2. I.5 J0.
G01 X2.75
Z.2 F25.
G00 Z.25
X2. Y-2.75
Z.2
G01 Z0. F5.
Y-2.25 F15.
G03 X1.5 Y-1.75 I-.5 J0.
G01 X-1.5
G03 X-2. Y-2.25 I0. J-.5
G01 Y-2.75
Z.2 F25.
G00 Z.25
M05
G91 G28 Z0.
M01
G00 G17 G40 G80 G90

1000006932.jpg
1000006913.jpg
 

Attachments

  • 1000006957.jpg
    1000006957.jpg
    6.4 MB · Views: 11
  • 1000006956.jpg
    1000006956.jpg
    3.5 MB · Views: 6
Last edited:
Got it running, I think! I used the atc macro picture I posted from the electrical manual. I corrected a typo of 1f to IF.

I also had to disable Tmac, or t macros in the base parameters. I had accidentally set the TMAC in macros screen to a program number, and I can't initialize it back to "0" as shown in the param book and its previous value (valid values in manual seem to be 1-999999). Not sure what that is about, because I read elsewhere that sometimes when a macro is set to 0 it does an internal PLC routine call. Still not sure everything is perfect, but it does tool change.
 
Got it running, I think! I used the atc macro picture I posted from the electrical manual. I corrected a typo of 1f to IF.

I also had to disable Tmac, or t macros in the base parameters. I had accidentally set the TMAC in macros screen to a program number, and I can't initialize it back to "0" as shown in the param book and its previous value (valid values in manual seem to be 1-999999). Not sure what that is about, because I read elsewhere that sometimes when a macro is set to 0 it does an internal PLC routine call. Still not sure everything is perfect, but it does tool change.
Did you lose all parameters at some point? I have the same machine. Lost parameters and can’t get it running…
 
Did you lose all parameters at some point? I have the same machine. Lost parameters and can’t get it running…
No, for the most part my parameters were intact. I did lose the macro.

I can send the parameter pdf from leadwell in this thread, though it's generic it seems my physical hard copy in the electrical manual has some slight differences / hand written notes.

There should be an image of the atc macro above. Anyhow, happy to share whatever I can.
 
I
No, for the most part my parameters were intact. I did lose the macro.

I can send the parameter pdf from leadwell in this thread, though it's generic it seems my physical hard copy in the electrical manual has some slight differences / hand written notes.

There should be an image of the atc macro above. Anyhow, happy to share whatever I can.

I don’t have a copy of the parameters. I would love it if you could share those with me. Thank you. I really just want to get rid of the machine tbh.
 
Cool, I'll try to get to it this by evening. Where are you located and why are you getting rid of it? I actually just got mine as a learning experience -- I'm new to cnc other than having built a diy linear rail machine. I'm able to make cuts, but seem to potentially have issues to address with the vfd, removable ROM, and the spindle definitely has seen better days, so we'll see how it goes on my end.
 
Here's my electrical manual, parameters start somehwere near halfway through. That took longer than expected, I had to take the photos individually then use some conversion scripts to put it into a PDF. I'll also attach the parameters from Leadwell themselves, but they seemed generic and my specific machine manual had more settings filled out

TDC 450 Electrical manual, includes machine parameters, Meldas M310 control, has 9001 ATC Macro and PLC ladder

 
Here's the shorter manual Leadwell sent me, seems to be generic, mine has more information filled out
 

Attachments

  • P20AEEQ451.pdf
    7.4 MB · Views: 9








 
Back
Top