What's new
What's new

Brother Speedio Tool Life/Workpiece counters

joecamel914

Plastic
Joined
Oct 21, 2021
I've got 6 new Speedio S500x2 machines that are making me feel quite stupid. I've managed to set up my programs, subprograms and tooling, and I can run good parts all day long.

The part that I can't seem to figure out is the Tool Life counter, and Workpiece counters. I can't get either of them to work properly and have no idea what I'm doing wrong. I am NOT a programmer, and I feel like I'm just missing something simple, hopefully someone can point me in the right direction.

I've tried adding M230 (for tool life) and M211 (for workpiece) in different parts of both my main and subprograms.

For the tool life counter, all of the tool life info is in the tool data and initialized, but it never counts parts.

For the workpiece counter, the M211 seems to activate counter #1 (it highlights the column in blue, at least) but again does not actually count parts. I've set the count increment to 1 so it SHOULD be, and I can't figure out why not.

Any advice?
 

Fal Grunt

Titanium
Joined
Aug 5, 2010
Location
Medina OH
I didn't know you needed a M230 :nutter:

I just go into the tool list, go to initial tool life, select 2, 3, or 4, enter a tool life.

And... it works?

Call your apps guy!

I realized it was STUPID of me to waste 5 minutes of my time trying to figure something out when Yamazen is always happy to help. Someday they might tell me I am annoying and to go away. Until then, I am going to keep asking them how to best utilize the machine they sold me.
 

joecamel914

Plastic
Joined
Oct 21, 2021
I didn't know you needed a M230 :nutter:

I just go into the tool list, go to initial tool life, select 2, 3, or 4, enter a tool life.

And... it works?

Call your apps guy!

I realized it was STUPID of me to waste 5 minutes of my time trying to figure something out when Yamazen is always happy to help. Someday they might tell me I am annoying and to go away. Until then, I am going to keep asking them how to best utilize the machine they sold me.

I don't think the M230 is actually needed, it's supposed to be active by default when you power up the machine. I just tried it out of curiosity. When I try to initialize with my current setup, I get a "No tool to initialize" or some similar message, even though the life and cycle info has all been entered into the tool data.

You got the M211 code on its own line before M30?

Yeah, M211 has it's own line right above M30. The workpiece counter highlights in blue once I added that, but the counter never moves. It's weird, to me at least.
 








 
Top