What's new
What's new

Carbide feeds and speeds issues

dreammstr6

Plastic
Joined
Mar 6, 2022
Location
Henagar, Alabama
Is this still the HTC endmill? I would strongly suggest trying something from a more established brand. That sort of failure pattern is too similar to what that other guy was describing. You might try using an air blast rather than coolant for a part or two also so you can see what is going on better.
Different tooling. I don’t remember which brand that was. Not wrote on it
 

dreammstr6

Plastic
Joined
Mar 6, 2022
Location
Henagar, Alabama
Is this still the HTC endmill? I would strongly suggest trying something from a more established brand. That sort of failure pattern is too similar to what that other guy was describing. You might try using an air blast rather than coolant for a part or two also so you can see what is going on better.
On the note of different brand. Was acting very similar until I increased the fpt. I went up to .001fpt same program I used for htc.
 

dreammstr6

Plastic
Joined
Mar 6, 2022
Location
Henagar, Alabama
Try upping the feed some more too.
Even the widia hanita which was tialn didn’t like it. I finally got it to run halfway. Running 25ipm 5511rpm 0.323 axial doc 10%radial and it still complains some. But running. It has to be across the pond junk steel. Nothing acts right. Oh I am drilling a through hole of 17.5mm for chips and the endmill to start in.
 

eKretz

Diamond; Mod Squad
Joined
Mar 27, 2005
Location
Northwest Indiana, USA
It is increasingly sounding like it. Good material is a pleasure to work with. Bad (especially so if inconsistent) material is a glaringly large PITA.
 








 
Top