What's new
What's new

Charmille 290p cabinet overheat alarms

rock

Plastic
Joined
Sep 15, 2002
Location
ky
I have 2 working 290p machines and picked up a spare machine for cheap to salvage parts off of eventually but it was said to be operational before the batteries went down and it lost the software.

This machine is a 1999 and mine are 2002 but mostly the same, console 2 control, only visible difference is hand pendant. I temp wired it and loaded the software from a 2002 machine and the control boots and passes the initial com checks but when it gets to the point of kicking in I believe k7 there are two overheat alarms. One for the servo card area and one for the power supply. Both occur at the same time and both are usually triggered by individual heat switches that open when temperature gets high in the cabinet. Obviously cabinet is cool so checked the heat switches and they are not open condition. Can replicate the alarms on a working 290 by unplugging the sensor cables.

The question I have is the power source for these sensors, the plug into the card in the cabinet where the main power comes in and its rear of the upr 1-4 cards near the top if that makes sense.

Anybody dealt with a similar issue. I think it may be related to a missing voltage that loops through these sensors on the way to either an input, relay, etc that says to the control all is well so it can kick in k7 and power the servo section. Thoughts anybody with a 190,290,310,510?
 

rock

Plastic
Joined
Sep 15, 2002
Location
ky
Saw there were several views but no comments on where to look. I had time this afternoon to really check the machine over. Went through every fuse, checked all the wire terminal screws, cycled all the breakers. Still had issue. Decided to pull and reseat all the individual pc boards. That's when I noticed the retaining bar was missing that holds the boards in the rack, removed by previous owner and not replaced. 851 7720 c had vibrated loose in transit, pushed it back in and problem solved. Machine boots as normal with no errors other than missing air pressure so I guess I will fill it with water, hook up a di bottle and its chiller and see if it cuts.
 

charmilles89

Plastic
Joined
Mar 5, 2019
Location
Grand Rapids MICHIGAN, UNITED STATES
Could be your if mac board all the i/o go thru there
Do you still need help i service these machines everyday?
Saw there were several views but no comments on where to look. I had time this afternoon to really check the machine over. Went through every fuse, checked all the wire terminal screws, cycled all the breakers. Still had issue. Decided to pull and reseat all the individual pc boards. That's when I noticed the retaining bar was missing that holds the boards in the rack, removed by previous owner and not replaced. 851 7720 c had vibrated loose in transit, pushed it back in and problem solved. Machine boots as normal with no errors other than missing air pressure so I guess I will fill it with water, hook up a di bottle and its chiller and see if it cuts.
 








 
Top