What's new
What's new

CNC Program Import Using USB/RS232 - extra file being imported

VHornblower

Plastic
Joined
Feb 15, 2022
Hi,

I have two Doosan lathes (FANUC 0i-TC), and I use a USB/RS232 system to import and export my programs into these. On my one lathe, I have no issues with importing and exporting the programs. On my second lathe, when I import from the USB, 2 program files are inserted into the CNC memory. The first is the one from the USB stick (e.g. O0014), but the second is a completely different program that I'm not expecting (O0015). I tried deleting all the programs off my USB, except for the one I wanted to import, but I'm still getting a second new program, and I don't know where this is coming from. The second program looks legit - it has perfectly normal G-code and comments. Also, it doesn't matter what the file name of my first program is (can even be O9XXX), and the second import will have the next available file name. Also, the second files imported seem to be the same program.

Would this be a parameter issue? I've been reviewing these, but I'm not sure what this would be.

Any ideas?
 

13engines

Hot Rolled
Joined
Jun 30, 2015
Location
Saint Paul
The few times when I've gotten an unwanted spare program showing up, it's because a parenthesis is missing on a statement or there is a letter O where a 0 or something else should be. Sort of still doesn't explain your situation, but it's my only reference to something close.
 








 
Top