What's new
What's new

communication problem

steve edm

Aug 8, 2010
florida usa
I have 2 Mitsubishi dwc-90 c wire edm machines. I have been running them with no problems for the last year or so until last week, The problem I'm having is... When I try to send a program to either machine with the RS232 cable there is no data recieved at the machine, no alarms either. I have tried other cables, different splitter boxes, checked the handshake data, and also tried to send and recieve from machine to machine with no luck at all. Is it possible that the RS232 communication ports in both machines have been damaged at the same time? Or is there anything else I can try? Any feedback is greatly appreciated.
They could both be victims of the same lightning strike. Is there a UPS/protector in their power path? With any luck, there will be a 232 line driver chip just past the connector... in a socket.

Do the onboard tests include a loopback test?

Do any software updates lately?

Are there other machines running in the local area at the time when you are attempting to transfer files? RS232 can be sensitive to external "noise" (RFI) created by other EDMs running near by.
Meaning the ones in the Mitsu's? Are there hardware or software configs for them, like xon/xoff, hardware handshaking rts/cts, 232/422 choices?

If replaced by a tech, did they work before he left?

I havn't had a tech in yet. No new software. I contacted Mits and was instructed to make a 25 to 25 pin RS232 cable to communicate from mach. to mach. I havn't had time to do this yet. Im still having a hard time believing that the com ports in each mach. could have been blown at the same time. I am double checking the hand shake as I write this.
As has been said, very strange to lose both simultaneously.

I doubt it's a hardware problem.

Are you sending from the same computer you've been using?

Has it been updated or upgraded recently?

Have you updated post-processors?

Is someone new editing your programs?

I have no experience with Mits, but our two Brother wire-edm's are very particular.

If the program isn't exactly correct they throw back all kinds of errors ...

... except when an "%" gets left at the beginning of the program.

When that happens, the machine apparently accepts the program as it doesn't give any errors ... but you cannot ever see or find that program.
Our programs start and end with '%' . I was just running the machine as I normally do and the following morning could not send program to either. We have done nothing as far as upgraading software, rebooting or anything else for that matter. I'm really stumped at this point.
Just a quick thought.........

when having problems such as additional machine setup I always send from machine to PC first as the machine side will tell you nothing if a wrong or missing character where as if your handshake and cabling correct the PC will show something if only Garbage from then to work from!
are you using a data switch, like a Black Box or similar? The problem could be there; if so, try eliminating the switch & hook directly to one of the machines and try it again....I ran Mits's for years, and we had a lot of trouble with downloading due to cheap cables that were ran beside flouresent lighting...