What's new
What's new

dmu50v S153 errors


Oct 31, 2019
Vista, CA
Hello all,
I have a 1997 dmu50v with millplus v320.
Recently I've been getting this S153 (drive not responding) error which requires a cold restart.
It usually happens when I close the door. Once, it happened when I jogged in the z-axis with the door open, but that was with an E130 (Spindle drive: No ready signal).
It never happens during a program, and I've run a few 2 hour ones yesterday and today. The really frustrating part is that a sensor on the ATC went out, so I've been changing tools manually, which requires opening the door of course.
I'm hoping it is the door interlock, and I will replace it being that I have an extra one lying around. What do you guys think it is?
Hi daffyff,
I have a lot of times the same error,in my case 16k2 switch was failing

That could totally be possible in my case as well. Mind if I ask how you figured that out? Because the door closed circuitry is pretty complex and replacing everything on it until it stops would not be ideal for me.
Every time it happened, the 16k2 switch was in a strange position, I moved the tab a couple or three times and everything was working normally again until I opened the door again. When I tried to close it, the same thing happened, I moved the switch tab and everything worked. The switch was a little stuck. Before replacing it, all the contacts were cleaned, and so far I have not had any more problems.
Thank you abelcnc,
Since your response I haven't gotten an S153+ alarm. But I have gotten a couple emergency stops from the machine that I was able to clear without a reboot. Annoying, but not as time consuming. I went ahead and tested all the K switch motions manually without power. They all seem to operate smoothly except for 5k12, which is part of the tool clamper circuit. I am not sure if or how it would be related to the S153(drive not responding), but may explain the E130(spindle drive: no ready signal) which only happened once.
On a side note, my ATC turret wouldn't rotate all of a sudden, but when I wiggled the connectors around in the back it was fine, so there's that. The damn thing is falling apart, basically. It breaks my heart because it's just so damn accurate and rigid and well made.
Hi daffyff
I'm glad the information was helpful to you.
I never had E130 alarm,Or at least I don't remember, I can look in my notes if it has ever appeared.
Quick update:
I have been operating in normal mode and have had almost no alarms. Before I was always in setup mode. Again I don't know if this is because the deadman switch is deactivated in normal mode, or if it is because there is a check failure in setup mode somewhere.
I'm not sure if this is related to the alarms I've been getting, but I was indicating a hole and thought I would test the rigidity of the machine. I wasn't expecting any movement, but when I pushed the head in the y direction it moved quite a bit, out of the range of the indicator, which is .030". It did not spring back, so when I closed the door it gave a Y04 "max following error too large."
I have never had any accuracy, precision or finish problems with this machine. The finishes and blends are actually remarkable. But it can't be a good thing to be able to move the head so easily. I simply have no idea what to make of it. I need direction on this.