What's new
What's new

Filling Oil Compensator- Maka Mortiser

Chaval AlHazman

Plastic
Joined
Sep 26, 2020
Hi, My Maka Mortiser is having trouble with its automatic feed- advance of Motor head (the motor head sits on the table and advances into the workload creating a mortise with its oscillating chisel)
I believe that this is due to a low oil issue. Basically, it has a high pressure oil reservoir underneath the table that has tubes running into the table which controls the feed. I don't fully understand how it all works, but I'll attach the diagram from the manual (which is written in German).
I'm trying to figure out how to pump this thing with oil through the fitting shown. I don't know what type of pump is suitable and the proper fittings...
Does anyone any experience with this or something similar? the photos attached are tilted 90 degrees to the right- can't get them standing ;)
IMG_5278.jpg
 

Attachments

  • IMG_5270.jpg
    IMG_5270.jpg
    95.2 KB · Views: 25
Last edited:

M. Moore

Titanium
Joined
Jun 8, 2007
Location
Vancouver Island, B.C. Canada
Two questions,
In the first photo it looks like they are showing you a 30mm extension on the oil level indicator, can you measure that indicator?
Second is there oil dripping out anywhere that would indicate a loss to the system?

It also looks like they are showing you the oil pump and adapter to use with this system, if it is not on the machine then you will have to adapt something else to get the oil in, like Stephen said.

Those Maka morticers are a very neat machine. I owned a manual one for a while and sold it many years ago. It doesn't seem like it should work but it works very well, the mortices are so smooth, the best in my opinion.
 








 
Top