What's new
What's new

HELP - old chinese machine, spindle on/off?


Sep 26, 2019

I just started working with an older Chinese made CNC. No one here knows how the thing works since the last guy who ran it left, and its taking a minute to figure out the interface.

my previous experience is with much more open or supported systems and machines (cncmotion, onsrud, komo, fanuc controllers, etc). this is all through a handheld keypad and menus, some of which I don't get yet.

The machine was made by "Beijing East Supper Star Electomotor" and dates to the mid 2000's. the controller software is a bit of a black box, with no tech support available. the manual is in English, but the translation is rough...

I have managed to home and zero and figure out how to set an origen and use the tool measure device/ set Z etc.

So far what I've run is a simple flycut program posted from Aspire with the generic G-CODE mm (*.tap). I cheated my z up to test run above the table, and this all seems to check out with the right feeds, location, motion as expected, etc. HOWEVER....


The spindle will not kick on. In manual mode there is a key on the handheld that will toggle displayed setting between SOFF and S-ON, but nothing happens.

when running the file I get an error message: "unidentified character, any key to show error line". The error line is always line 4: which is always: G0X0.000Y0.000S12000M03 This looks completely correct to me? am I missing something obvious or dumb here? I've looked at a few previously cut and archived files and they seem to have the same syntax, and while I'm not an expert at G-CODE programming, this is pretty basic...

I'm worried that in my initial scroll through various settings in the controller I mucked something up? the machine was cutting as recently as June from what I gather, with no collisions or major events since then. basically dormant until I switched things on a few days ago.

the spindle turns freely by hand.

Any tips or starting points on what to look for or begin troubleshooting this would be super helpful.

Is it possible 12,000 RPMs is over the speed capacity of the spindle?
quick follow up:

if I delete the "S12000M3" from that line it runs without throwing that error message. still no spindle of course...
the spindle is 5.5kw and rated 3000-24000 rpm per its labeling, also I've seen some previously programmed files with speeds at 14k and 21k.
Start simple, do the previous programs work?
Does the control display RPM?
If you turn the spindle by hand does it give you an RPM value?
Does the control have an MDI page and can you get the spindle to turn from there?
A few more lines of working code would help. Your code looks ok aside the fact there is no work offset called, But then you may have called it earlier in the program. That Jin-Jin control is a real piece of work so hope you are patient. You posted S12000M3 all bunched together. Is this the way you really have it on the control? Should have a space between the S120000 M3. Also If memory serves me correct the M3 has to be before the speed call on that bundle of joy.
so all the programs have the same basic header before going into cut motions:


The post is generic so other than calling the XY plane with G17, there isn't any particular work offset called. The machine has a home location that is hard set, but the work origin is set by jogging to a location and hitting a button. everything is then based off that, including any coordinates you can see in the handheld.

All the programs I've tried all throw the same "unrecognized character error" unless I delete out the "S" (spaces and order of M3/S don't make a difference)

There doesn't seem to be any MDI as I'm familiar with it. either run program or manual mode. There is a keypad button that should turn the spindle on/off in manual, but I don't see any RPMs shown anywhere and nothing happens at the spindle, though S-ON/SOFF display changes. As I've been able to parse the manual, one should be able to adjust the spindle speed while running.

I've ID'd the controller as RZNC-0501. There is a "spindle setup" menu with "spindle states" and "lines states". Don't understand that, but my next area of trial and error I guess.
If it's not too much to ask could we get a picture of said confounded contraption? I'm really curious as to what this thing looks like.
I did find a website for the controller vendor ("best and cheapest!") was a little nervous about a random Chinese website but installed their software update anyway. no longer get the g-code error message, but the spindle still doesn't come on in auto or manual. I can induce the error message by inserting some gibberish in the code, so the error checking is working. I did have to reset some basic machine settings (table size, dimension of the z/tool measure)after the update, so there may be some other things still at default settings.

other than loose wires or connections, any advice on how to troubleshoot on/off signal not making it from controller to spindle?

thanks in advance for any and all ideas.

Wild guess, does the VFD show any change when the M3 is issued?

Maybe the signal is not getting to the VFD?

Do you have any schematics?

Thanks for the replies so far, I'm definitely learning a fair bit on the fly here and the help is much appreciated.

so I'm a bit out of my depth on troubleshooting the VFD, but I think you may be on to something that the issue is with the controller communicating with the VFD. Today's project is probably going to be better understanding that interaction, here's where I'm at:

I got the spindle to kick on and run a flycut routine. I'll double check, but I don't think the placement of the 'M3' made any difference. Rather, I changed the 'SPINDLE SETUP' settings, based on some poorly translated instructions specific to this controller I found online. I don't quite know enough to fully make sense of exactly what I did, but you can set the 'Input Spindle State' to 2 4 or 8. Then set that many 'line states' with a different 4 switch sequence of up/dwn arrows for each. Right now I have it on the 8 state settings.

In manual mode, the RPM jumps between a series of static RPM, rather than being continuous. When I've run the flycut routine, the spindle speed jumps to the highest of these set RPM rather than the RPM in the Gcode. I can work around this by adjusting the feeds, but not ideal...

pic of VFD:

RZNC-0501 Diagram.jpg

Ben HD
not my $, not my call. sadly.

also just started here, so still feeling out how that convo would go.

The longer I can get this to last, the more $ for a legit replacement there will be essentially.
I can now get the spindle at 7 different spindle speeds. I have to set them at the controller, rather than via CAM or g-code it looks like, and don't know what they actually are despite some success cutting some mdf at the fastest.

this should be workable moving forward if I can know what those speeds actually are. It will be like changing belts on a drill press. ;)

the "speeds" I'm able to run at are 215, 430, 645, 860, 1075, 1505, 1720 Hz. the last one feels like something in the 18-20k rpm range, but I can't be sure.

I've found some posts about calculating rpm from hz on here, but none of the info/formulae I've found matches the range I'd expect. or are for motors/mills rather than high speed spindle. any ideas? spindle is 220vac, 5.5kw and possible rpm range should be 3-24k.