What's new
What's new

Leadwell MCV1300 Fanuc OM Tool Changer Issues

RC Mech

Jul 21, 2014
Ontario, Canada
Have a 1992 Leadwell Fanuc OM, tool changer hung up and will not cycle now. The problem is I cannot remember all the steps to reset the ATC.

In MDI mode:

PWE = 1, scroll to Diag. D0441, make sure this number is the current spindle Tool #.

Diag. D0440 is the carousel capacity, 0020.

Change Diag. D0447 to current spindle Tool #.

Reset, PWE = 0, Reset alarm. Tool changer still doesn’t cycle with an MDI command. The Tool # changes on the MDI command screen (shown below) but the ATC does not cycle. I’ve tried ensuring the carousel, MDI screen and Diag. tool numbers all match, no dice.

I’ve tried shutting the machine down after changing the diagnostic #’s. No dice. There has to be more to this procedure than I’ve written down in my notes.
I do not believe Campat is a leadwell distributor anymore. About a year ago we asked about parts and they said they didn't distribute for leadwell anymore. but they did happen to have the parts in stock.

I just looked at our 1300, it's from 1996. I don't expect it is much different than yours.

So currently I have tool 20 in the spindle and pocket 20 facing the spindle. 440, 442, 445, 447 are all 20. also manually index the turret to 20. Try that.

Next thing to try if that doesn't work, is are you sure that the spindle orient is working? In MPG mode, hit the spindle orient button. if it doesn't orient, then the tool change is getting hung up on that.

If the spindle does orient, then I'd be looking for Y diagnostic outputs for the solenoids that make the umbrella move towards the spindle. If the machine is giving the Y output for the ATC to move towards the spindle but it isn't moving, then it is very possible that either the relay has failed for that solenoid, or the solenoid itself has failed.

Again, my machine here is from ~1996, so this might not be the same, but according to the electrical manual, y53 bit 6 is the magazine right solenoid signal, which powers relay 53. Refer to your manuals if you got em, to see if it is the same.

And actually, there are M-codes to see if certain functions are working. My manual suggests that:

m21 tool magazine right
m22 tool magazine left
m23 tool magazine up
m24 tool magazine down
m25 tool clamp
m26 tool unclamp
m11 auto magazine cw
m12 auto magazine ccw

If any of those don't work, they could also be the issue.

Edit to add: also, i am positive you already know this, but make sure the machine is homed in Z.

Double edit: Also make sure the thing has waylube and air pressure. it IS possible for the indicator lights that tell you its low on waylube or air pressure to burn out, which can cause issues (although I would expect the "current command" to not go through with cycle start)
Last edited:
Dan thank you.

I can step through all the motions on the ATC via M code. I was making a list of what worked when I saw your reply- moving the carousel to the spindle or away were the codes I couldn’t figure out.

So yes, all functions of the ATC work per the M codes. That would mean the relays are good.

Air pressure is 155 psi at the machine, regulated to 110 psi on the machine. Low air light works, ATC ref return light works.

I tried the T20 in all the diag parameters, with the carousel at T20 and machine thinking T20 was in the spindle. No dice.

It hangs on the M6 T# when input in MDI. The T# changes in the CMD screen but nothing happens. If I can actuate the steps manually, this is a parameter issue?

I say this as the Mori w/Fanuc M6 sitting next to this machine has a parameter you need to change a bit in when the ATC is recovered.
Is the ATC ready indicator lamp on the control lit up before you run it?

Also did you confirm that the spindle is orienting with the orient button on the control (or M19)?

Also, do you have the electrical manual for the machine? because if we start digging into the diagnostic bits / ladder, it would be helpful to have that in front of you, in case my newer machine's ladder is not the same as yours. I expect them to be similar, but that doesn't mean they are exact enough.

The ATC indicator is lit, yes. Spindle orient works both with the button on the panel and with an M19 command.

If I call a tool in MDI, nothing happens. When I manually close the limit switch for carousel DOWN position (while it remains UP), the carousel will index to the called T#.

I do have the electrical manual for the machine. I’ll be going through this today.
I do not believe Campat is a leadwell distributor anymore. About a year ago we asked about parts and they said they didn't distribute for leadwell anymore. but they did happen to have the parts in stock.

Just went to the site. Yeah, certificate hasn't been updated. They do list the full line of Leadwell products. Maybe the site hasn't been updated in three years either.
Last edited:
Campat is listed on leadwells website as being a distributor but even when you click the map, they are limited to texas and a few nearby states. every other state has MAG in michigan as the distributor. Anyway my company had always turned to Campat for parts, was told by my boss they said they were no longer distributor for them. But I didn't talk to them personally. They were always helpful by phone.

As for the manual, great! My manual is similar but newer. My machine here has alpha drives, not the old digitial servo drives. And the version on the cover is M9509-01/K2 So they are not the same version. But again, I do expect them to be very similar.

Another question: does this machine have an enclosure or is it open? Just making sure there's no door interlock.

To be honest, I find trying to help while not in person is going to be difficult. I feel like i could find the problem in 10 minutes or less if I was there, while it takes 10 minutes just to type out this one thing. I hope you know how to read the ladder and can navigate/search for signals you need to check.

To give a general rundown on what I'd check first, I'd be checking to make sure that the machine sees that the spindle is clamped and not simultaneously unclamped. I'd also check to make sure that the machine sees the location of the ATC, both left/right and up/down.

In the electrical part of the manual, my book says
tool clamp is x19.3 and unclamp is x10.4
magazine up is x10.5 and down is x12.0
magazine left is x14.1 and magazine right is x14.6

If any of those pairs are both on at the same time, I would expect an alarm, but maybe yours does not have an alarm for those.
If any of those pairs have NEITHER of them on, then there might not be an alarm (I didn't look further into this), and that would probably be the culprit.
I am wondering if the limit switch is out of position and it preventing it from moving, wish I knew how to move it, I've only went into my electrical cabinet and reset a breaker in there and manually make the contacts go in for the motor to fix it when a manually put in tool holder wasn;t fully inserted into the umbrella.
Yeah, I'm thinking one of the limit switches is dead, so while the magazine and clamp are sitting where they should be, the machine might not see one of them, and wait for it to happen.

Now, I don't think this is the issue, but I realize that diagnostic parameter 444, 449, 454, and 459 are all 0 on my machine. I don't know if that's your issue, and I don't see any of those bits listed in my manual.

I will say that 444 and 449 bit 0 (xxxxxxx1) turns to a 1 when the motor that indexes the turret turns during a tool change. The machine uses those to count.

When you index the turret manually, does the pot number facing the spindle change in the diagnostic parameter?
As far as I can tell there are no limit switches for Carousel Right or Left. When I do a “tool change”, it hangs and I can manually close the Carousel Down limit switch and it will index to the requested pot.

I believe it’s something to do with the Carousel Right (toward spindle) command.

I can get it to hang up and become non-responsive. When this occurs, you cannot enter anything in MDI. I can then change the D0441 diag. parameters, reset, then MDI will take a command like M3 S2000. This tells me it’s taking the diag. parameters?

I tried swapping the relays on the large Leadwell board, no change.

What # is the relay for Carousel Right/Left?

Edit 1- I forgot about the Tool clamp/unclamp. I’ll take the shroud off and clean the switches with contact cleaner, verify in the ladder that state is changing.

Edit 2- Not getting enough air at the machine IMO. Compressor says 150 psi, line to machine is weak, old Festo reg on machine says 50-70 psi. Changing regulator and plumbing 3/4” pipe to rear of machine tomorrow.
Last edited:
Have you tried emailing leadwell directly? I also have a Taiwanese mill of a different brand and needed a manual and the headquarters got right back to me (a bit newer machine but worth a shot)

From their website:
  • No. 8, Xingke Rd., Houli Dist., Taichung City 421, Taiwan (R.O.C.)
  • Tel:886-4-25589008
  • [email protected]

A few things to unpack here.

First the air. If you try to do a tool change with low air, it should give an alarm. Also the status alarm light for air pressure should be low. Doubt that to be the cause.

Second, the switches for the left/right on the ATC are probably visible from the back of the ATC, you probably don't even need the cover off. On my machine they are actual switches with rollers on them, not proximity sensors, and they are near the top of the ATC unit.

3rd: what color is this machine? Is it white with blue, or is it green with white/beige?

4th: Have you compared these with yours:

In the electrical part of the manual, my book says
tool clamp is x19.3 and unclamp is x10.4
magazine up is x10.5 and down is x12.0
magazine left is x14.1 and magazine right is x14.6

Those are diagnostic bits.

5th: Also, earlier on you mentioned you used all of the following M-codes:

m21 tool magazine right
m22 tool magazine left
m23 tool magazine up
m24 tool magazine down
m25 tool clamp
m26 tool unclamp
m11 auto magazine cw
m12 auto magazine ccw
m19 spindle orient

You said they all worked when you ran them as one-shot m-codes. Now what I should have asked was, do any of them HANG when you execute them? When you execute them, they should FINISH, meaning the code you typed in MDI should go away. If it doesn't, then the M-code didn't finish and you should be looking closer at that.
IMG_0162.jpegGot this sorted!

First of all, bless everyone who attempted to help me here. This forum has its issues but you guys are why I keep coming back. Excellent, thoughtful advice from everyone in this thread.

I’ve been messing around with this since April the odd day after everyone else goes home. I had the cabinets opened and cleaned, traced every wire I moved when I repaired the Y axis cable carrier (25ft long cables going thru enclosures and track to the other side/back of the machine). Figured I bumped something, was tearing my hair out.

Dan and Vanc called it. It was the GD carousel limit switch, Carousel Right. Was stuck depressed. Moved further into the housing when I pressed it but wasn’t extending out to open the switch.

Got the mill changing tools. I have two 60 gallon tanks to plumb in behind the machine to deal with pressure drop when changing tools. This thing uses serious flow when moving the magazine, purge, blow, up/down.

Forgive the mess. Wasn’t continuing Operation Spit Shine until the machine was operable.

Thank you all!