What's new
What's new

Mazatrol Nexus - Tried running big EIA program. Buttons stopped working?!

Isak Andersson

Aluminum
Joined
Nov 3, 2021
This one I can't even begin to explain. These are the steps I took to get this glitch:

1. Tried to transfer an EIA program. It does some high-speed milling so it's pretty big. 701KB. Couldn't do it the conventional way so I had to go into Windows XP and copy-paste the file, then change the name so the controller could find the program.
2. Then I tried simulating the program but the virtual machine would go slower and slower and it was taking over an hour (!) just to run the simulator. So I said, fuck it, and decided to run the program without first simulating.
3. So I ran the program but halfway through the tool broke so I had to stop. I made some changes to the program and tried to transfer the new version. That's when all the buttons on the controller decided to stop working. I can still change mode from memory to hand jog etc. but everything else is gone. Tried restarting the controller multiple times. Nothing.

So what the hell is going on here?
 
Call the tech. I had similar on a Mori. Big program cutting a reverse taper in UHMWPE with a lollipop cutter. Machine would freeze solid and nothing would work. Have you tried shutting down the entire machine not just the controller, that's what I had to do to get going again. My Haas SMM2 occasionally does it also.
 
I think it is a hard drive. U started to write data into C drive and by doing it update MBR and now Windows gone mad as you have bad sectors. U need to disconnect drive and attach it to another PC and see if HDD recognizable and can be accessed.
 
Moving forward maybe split it up into more programs and just link them all together in a main. Good luck
 








 
Back
Top