What's new
What's new

Mori Seiki SL-25Y Y0. at Turning Operation

WNP

Plastic
Joined
Jan 26, 2022
Hi, I am using Lathe 4 axis Mori Seiki SL-25Y controlled by Mori MF-T6 (equivalent to Fanuc 16T)

I want to fix Y at zero when do turning operation but machine show an alarm EX2018 Y-axis Mode when I try to
rotate spindle. I have a problem with Y-axis off-center when deactivated so I want to fix Y0. all the time to
eliminate this problem. Any suggestion or do you know which parameter I have to set.

Any suggestion is appreciated.
 

chad883

Cast Iron
Joined
Jan 12, 2012
Location
indiana, usa
I have the same machine and to the best of my knowledge the Y axis sets on a block for turning. I say this because of the procedure to manually recover back to turning mode. You have to move Y+ and soft key to block out and then turn off Y axis. I have not been into this mechanically to say for sure what is happening. Are you sure your turret is clocked correctly? As in rotationally in the correct position to have everything centered.
 

WNP

Plastic
Joined
Jan 26, 2022
I have the same machine and to the best of my knowledge the Y axis sets on a block for turning. I say this because of the procedure to manually recover back to turning mode. You have to move Y+ and soft key to block out and then turn off Y axis. I have not been into this mechanically to say for sure what is happening. Are you sure your turret is clocked correctly? As in rotationally in the correct position to have everything centered.

Hi, chad883

The procedure to manually recover back to turning mode is the same for me. So, that mean I can't use Y axis while turning, right? What can I do if my tool is off center I can't set Y offset.

But I just know my real problem is when Turn on Y and go to Y0. that is not the line that pass center. It looks like Y was shift about 2.3 mm. but the controller show 0. When turn off Y with M320 at home position, it will go to Y-2.3 automatically and turn off actually that is quite center. So, I think my problem is at Y encoder or some parameters setting.

Anyway it would be great if I fix Y inaccuracy position showed and can use Y all the time no matter milling or turning to compensate tool off center with Y offset.
 

chad883

Cast Iron
Joined
Jan 12, 2012
Location
indiana, usa
I always turn off Y for turning with M320. I have not been able to figure out how to turn with Y turned on. I wish I knew how to turn with Y engaged so I could get drills dead on center. I do know when I turn on the Y axis it is not at Y0. I have to program it to move to Y0.0 after M321. I would just turn it off so you are on center and then the Y servo is not trying to hold that position. I would think that you would get some movements to hold Y in position under heavy turning ops.
 

WNP

Plastic
Joined
Jan 26, 2022
I always turn off Y for turning with M320. I have not been able to figure out how to turn with Y turned on. I wish I knew how to turn with Y engaged so I could get drills dead on center. I do know when I turn on the Y axis it is not at Y0. I have to program it to move to Y0.0 after M321. I would just turn it off so you are on center and then the Y servo is not trying to hold that position. I would think that you would get some movements to hold Y in position under heavy turning ops.

I watched videos from Haas. They have screw at tool holder to adjust off center so there is an option to adjust by mechanic not controller but mine don't have that.

Thankyou chad883, I appreciate your sharing.
 








 
Top