What's new
What's new

Mori Seiki Turning G92 issue

Caracu

Plastic
Joined
Jan 27, 2022
Hi

I have a Mori Seiki with Fanuc 10T control. I already use this program to make parts on this machine.
One beautiful day, the machine start showing alarm "PS190 Parameter zero (Cut Max)" on the line G92 threading cycle.

The program is like this:
N50G50
G00G21T0505
M42
G97S1300M03
X-33.Z2.M08
G92X-36.2Z-26.F2.117
X-36.5
X-36.8
X-37.1
X-37.4
X-37.7
X-37.9
X-38.1
X-38.1
G00Z100.M09
X-200.
M05
M01
M30

I already checked the parameters, looks ok. Parameter 1422 is set 600. I don´t understand why this alarm because this program already work on this machine.

Any idea??

Thanks
 

Attachments

  • Monitor_1.jpg
    Monitor_1.jpg
    91.2 KB · Views: 5

angelw

Diamond
Joined
Sep 10, 2010
Location
Victoria Australia
Hi

I have a Mori Seiki with Fanuc 10T control. I already use this program to make parts on this machine.
One beautiful day, the machine start showing alarm "PS190 Parameter zero (Cut Max)" on the line G92 threading cycle.

The program is like this:
N50G50
G00G21T0505
M42
G97S1300M03
X-33.Z2.M08
G92X-36.2Z-26.F2.117
X-36.5
X-36.8
X-37.1
X-37.4
X-37.7
X-37.9
X-38.1
X-38.1
G00Z100.M09
X-200.
M05
M01
M30

I already checked the parameters, looks ok. Parameter 1422 is set 600. I don´t understand why this alarm because this program already work on this machine.

Any idea??

Thanks

Hello Caracu,​

The 600 value in parameter 1422 is in units of either 10 or 100 mm/min, so 600 should be at least 6000 mm/min. You have a spindle speed of 1300 rpm and a feed per rev of 2.117mm, therefore:
FPM = 1300 x 2.117
FPM = 2752.1
Where:
FPM = Feed Per Minute in mm per minute.

therefore, the slide velocity should be well under the maximum. Just as a test, change the feed rate to something small, or decrease the RPM considerably, to see if the problem persists.



Regards,

Bill
 
Last edited:

Caracu

Plastic
Joined
Jan 27, 2022
Hi Bill

Thanks for your reply.
I thought the same think like you. I already try to reduce both values, like S200 and F1.5 and still showing same error.
I found today a friend with same machine and this program work on his machine. My idea is if this function is activate on my control.

I already read the Fanuc 10 manual and cannot find nothing relative to this G code...

Any idea??!?
 

angelw

Diamond
Joined
Sep 10, 2010
Location
Victoria Australia
Hi Bill

Thanks for your reply.
I thought the same think like you. I already try to reduce both values, like S200 and F1.5 and still showing same error.
I found today a friend with same machine and this program work on his machine. My idea is if this function is activate on my control.

I already read the Fanuc 10 manual and cannot find nothing relative to this G code...

Any idea??!?
Hello Caracu,
Do you mean the G92 cycle with your reference to available function? G92 will definitely be available as a function of some description with the FS10T control, depending on the G Code System selected via parameter.

If G Code System A is set, then G92 will be a Threading Cycle. If G Code System B is set, then G92 will be for setting the Work Coordinate System and clamping maximum RPM when using Constant Surface Speed spindle control. Also in the case of G Code System B being selected, G78 will be used in place of G92 for the Threading Cycle. If you use G50 in your programs to clamp the maximum spindle speed, then G Code System A will be set and G92 will be for Thread Cutting.

Because of the error you're getting relates to feed rate, I suspect that your control is set to G Code System A and that G92 is in fact for Thread Cutting.

As another test, write a simple program which includes a G32 feed line (G32 Z-40.0 F2.117 for example) using the same spindle speed of S1300 and Feed Rate of F2.117, to see if you get the same alarm.

Regards,

Bill


As another test,
 








 
Top