What's new
What's new

Need Help, adding 4th axis to Mitsubishi M64-B control

chevydyl

Aluminum
Joined
Nov 23, 2014
Location
Sterling, Ak
so like the post says im adding 4th axis rotary to my vmc, awhile back i did a control retrofit swapping in a M64B from an M50, the original PLC i hand entered has all the 4th axis ladder already. the machines wiring was already done for the A axis. i added an MDS-B-SVJ2-06 and an HA40NT motor, i changed the parameters and have the motor spinning and showing encoder counts. my questions are concerning what the switches in the table are. im guessing the 2 next to each other are the clamped/unclamped limit switches, and the single is the reference or home. the table is an MMK Tecnara 9in. i have the wiring diagrams for the machine, on the machine output side it says M71 Index goes to a solenoid which i believe is the solenoid on the air/hydro booster.
now what i see in the diagram are a limit switch for reference, Normally Closed, and a limit switch for Index Complete, Normally Open. The single limit switch is currently wired NC. when ive tried to run a program with 4th it errors and says axis not referenced so im pretty sure im good option wise, since my M64 has a different option file than was given with the M50. here also is a reference picture of the switches in the table. does the M64 control need the Index Complete signal to work? i was mostly interested in using this for simultaneous 4 axis machining. thanks for any help.rotary1.jpg
 

Vancbiker

Diamond
Joined
Jan 5, 2014
Location
Vancouver, WA. USA
It is most likely that the index complete signal is not used with a true 4th axis, but with a simple indexer. If you are getting the axis not referenced error that means that the axis was not homed properly before you attempted to run a program. Did you home the axis and see an indicator showing it was homed?
 

chevydyl

Aluminum
Joined
Nov 23, 2014
Location
Sterling, Ak
i havent hooked up those wires yet, thats why i posted mainly cause i wanted your input, i wired in the toggle, the indicator and i just need to slap together a harness for the limits on the table, was just wondering about that M71 index complete if i was gonna need another switch or what, although im not sure my air/hydro booster is working as when air is hooked to it and i power the solenoid nothing happens, the solenoid is 100vac. im not sure if i need to bleed it or what. but the plunger doesnt move. i was able to get some sound coming from it like a discharge of air sound but im not seeing oil travel through the tube so i wonder if i need to crack that open as well.
 








 
Top