What's new
What's new

Need help with Error 20 on my Deckel FP2NC Dialog 3

spaxxomatic

Plastic
Joined
Dec 12, 2017
I am a passive reader here since many years, got tons of valuable information and tips from you, guys. Thanks a ton for that.

I bought an FP2NC a couple of years ago for my hobbies, put it in the garage and loved it. I thought the old lady will love me forever too and never die.
Until two weeks ago - I left it on over night and next day I had an Error 20 in the right corner of the screen. Looked it up , it's "Fehler 20 - Eprom error on NPP53 or NEP51".
I knew this day would come, but I was too lazy to make copies of those pesky eproms in time.

Anyway, my background is electronics and software, so I thought, not all that bad, my baby needs a bit of love and some new eproms. So I bought the Eprom images for this version of Dialog 3 from a guy, built myself a programmer (need to build one, no modern programmer for less than 1000$ can handle those pesky TMS2564 eproms),
I then took the NPP53 and the NEP52 out of the machine, fought the 40 years old eprom sockets to free up the damn chips, then compared the chips with the images I've bought and found indeed 2 bytes that were different.
I was almost happy - thought OK, problem is localized and easy to fix.
So I burned some new old stock TMS2564 with fresh bits, put them back in those miserable sockets, turn the machine on and ... "Fehler 20".
Exactly the same shit. I can't believe it.
I then tried everything - replaced eproms one by one. Checked the NSP voltages, removed NSP board, NEP board, pulled the eproms from the sockets and started the machine without them. The machine starts and displays exactly the same error 20 .- the only change I could see is a black screen when the NPP53 is completely removed or when the IC18, the first eprom, is removed and the NPP started without it.
Which makes me conclude that one of the first things that happens when the machine starts is some checksum test, the routine being on IC18, and the test is failing for some reason.

So what to check next? I have no idea how to continue from here. Replace the NPP53 board completely? It's expensive and I don't think the defect is on that board ..
Replace the IC's on the board one by one? Hunt some signals with an oscilloscope ? EEproms are 100% ok, so is there maybe some peripheral logic chip that died ?
Any advice ?
What can I try next?
 
I have two sets of spare D2 boards. One is the spare set I bought from Ross and the other is the set that came in my FP2NC. I ran into board problems a couple times, so having the spare set was good insurance and made it easy to solve the problem. I have since upgraded to D4, so first thing I did after that was to buy a spare set of D4 boards. Suggest you look for a spare set. Check with Martin, he has been a great source of parts for me.
 
Thanks for the advice, having some spare boards is a good idea indeed.
I'm located in Germany, I'll have to find them locally, there are plenty of them but expensive.
Did you really had an electronic defect on the board itself? The NPP53 is really simple, an microprocessor and some logic IC's around, it seems to me somehow improbable that one of those TTL logic circuits is the culprit here. Rather some oxidized connector or dried out capacitor, in my experience.
 
So I bought the Eprom images for this version of Dialog 3 from a guy, built myself a programmer (need to build one, no modern programmer for less than 1000$ can handle those pesky TMS2564 eproms),

Hi, Martin here.
Hello nameless,
Dialog parts have gotten pretty cheap, but if you need one "right now" it's too late of course.
To the quote above: who did you buy Eprom images from? Also the standard cheap Eprom programmer from China can do the TMS2564. I think it is 50€.
The D3 is half D2 and half D4, I have to see which version it is and also to see what SW version is on there. I assume there are different SW versions.
 
Last edited:
Hi Martin, thanks for replying. I have the eprom versions 44206-301.26 on the NPP53 and NEP51

Which china programmer do you mean? I could not find any that explicitely supports the TMS2564

Anyway, my programmer built around an raspberry pi works 100%, I'm sure the images have been burned right, checked and double-checked them many times.

I've bought the images from a guy called Michael, found him on kleinanzeigen.de, he sent me files with the version 44206-301.28, but as said, it seems that they are basically identical with my version, I've found only 2 bytes changed on IC18 and IC24 of NPP53.

I've replaced all eproms from NPP53, NEP51 and then, after still getting the Fehler 20, burned and replaced the eproms for the NPP54 or so, because I saw on the schematic that this board also shares the data/addr bus with the NPP53.

Looking at the schematic, the data and address bus is not shared with the NRP53. This is the position controller, gets ist/soll position info and controls the servos afaik,. This "Rechnerkarte" communicates with the NPP "Masterprozessor" via the VG1 (lower connector), which goes through those PIO MC6821 chips, not directly on the data/addr bus. So there is a good functional separation between position control and g-code processing.
My intention was to get the machine running again and then use a logic analyzer to trace the traffic between NPP "master prozessor" and NRP53.
I intend then to replace the whole "master" part with a PC and directly send movement instructions to the NRP53. I assume it can't be very hard ot reverse-engineer the protocol between NPP and NRP, it must be something like "go to position A on axis X with speed S", or maybe even step/dir pulses. Should be imo easy to understand.

But as said, the main problem now is this error 20 - either the NPP/NEP board is toasted or the error cause is not the eprom content, but some other remote board.
 
Right, Michael Burk is the source.

>> am confused why you reference NPP53 AND 54 and also NEP51 AND 52.

I might have given the wrong numbers - my cards are NPP53 + NEP51 , NPP52 and NRP 53. So, classic DIalog 3

Anyway, I've found the error. I remembered that the schematic of NPP52 and NPP53 are similar - except that on the NPP53 physical board some components are not populated (those for the interface "Serial PC")

So I began swapping IC's from NPP52, then turning the machine on and see if the error persists. RAM, logic - everything what was socketed. one by one, moved from NPP52 to NPP53, pluging the card in, restart.

And voila ! it was the CPU itself, the MC6809. After swap, the error changed to 01 - which now comes probably because the NPP52 is not installed

Very strange error, Never had a CPU "half dead". I mean, the defective one was still half alive, because it was able to send out the error 20 ....
Anyway, I ordered some 6809, I'll let you know how the story ends after I install them.
 
Just a tip for those going through the same pain as me - if you need to replace the CPU, take care to buy the MC6809P and not the MC6809EP. They are not identical - the difference is burried in the datasheet, the EP needs an external clock, the P variant can drive a quarz itself.
 
Yes, today I got the MC6809P, after buying two MC6809EP and despairing. Luckyly somebody on another forum gave me the tip that P and EP are not compatible: The information is deeply burried in the datasheet and I overlooked it.

And voila ! It's all good, everything works again.

Next step is to capture the bus traffic as mentioned before and then reverse-engineer the comm protocol between NRP53 and NPP52. I have bought a logic analyzer, I've built an adapter cable and a board with bus buffers, need to write a bit of software for the NI3264 capture card and I'll give it a try.
I think I can make a lot of Deckelians very happy if I succeed, it would be a very low cost conversion to LinuxCNC or any modern PC-based motion control software, and all legacy functions would still work.
 
I have huge admiration for the creativity, patience and determination of people who are able to build real things from metal. I'm an hardware / software engineer, in my craft accuracy doesn't matter, hardware is cheap, iteration cycles very fast, but the work in front of a screen will never bring the satisfaction that one gets by building real things.
My attempts to build something real from metal are painful, I am missing patience, determination and imagination. But I am learning a lot and getting a bit better every day.
With the AI revolution coming, 80% of the white collar jobs will be exposed as that what they are: bullshit jobs. And people doing real things will be rewarded huge - their jobs are safe, they will be always needed. No machine will ever be able to replace what a skilled craftsman can build with his hands.
 
Last edited:
With the AI revolution coming, 80% of the white collar jobs will be exposed as that what they are: bullshit jobs. And people doing real things will be rewarded huge - their jobs are safe, they will be always needed. No machine will ever be able to replace what a skilled craftsman can build with his hands.
I'm glad you think so. We need optimists right now. Software engineering is particularly vulnerable, since it is all mental work. And that includes CNC programmers. It reminds me of a few years go, I had to train an Indian engineer to take over my job. That was the second time. There will be a big demand for creative people to train AI in various tasks, but that demand will not last long.
 
I am renovating a house. No way a robot will be able to build a structure, plaster and paint a wall, put tiles in the bathroom, mount a door, change my car tires. There will be better helpers, but the skill and the brain of a real human are not so easily replaceable.
And in the software industry things are not much different - I am doing software architecture for a living. The AI is able to write some basic code at the function / module level, but it has no imagination, no vision, it cannot work with abstract concepts. AI is an excellent assistant, but a very poor architect. It can be a good project manager, though.

Back to the topic - just for the record and for the people having troubles with Deckels electronics - here my observations on the behavior of the machine with regard to the NPP cards:
NPP53 card faulty -> Screen shows "Fehler 20" ( EEPROM error on NPP53) - but note that in my case the CPU was deffective and the eproms were OK.
NPP53 card missing: screen stays black, no message whatsoever.
NPP52 missing: Error 00

When the machine is powered up, the LED's on the right side of the cards NPP53 and NPP52 are initially on. The LED turns off after some seconds, when the card is OK. Probably some internal check or some "OK" signal is turning them during bootup.
 








 
Back
Top