What's new
What's new

New to me 1997 Kitamura Mycenter 2x

Don't just stop at the thermals in the electrical cabinet. Often there will be one or two in the chiller electrical box and sometimes in a chip conveyor operation box.
 
Not saying you dont have thermal issues but maybe you have a pulse generator issue. If the servos are on and not moving and doesnt attempt to and then alarm because it overtourqes then its not trying to move… maybe try switching to jog mode and then the axis you want the. Use the jog +/-, I run a I80 kit mycent1. Feel like my tool changer has done that and i just moved carosel by hand and it found were it should be locked and stopped being dumb
 
What voltage does your machine want? Mine wants 200 but the first thing to trip is at 265, and is some Mitsubishi thing in the back, which may be it. Like Vankbiker said, look around.
 
I run mine right where yours is for several years and no issues, mine is on a adx 20 rotary

Mitsubishi thing is a 24v dc power supply for something cant recall maybe a card?

IMG_2490.jpeg

Id also check this line of “breaker doodads” ive triped one before and got weird issues there real hard to tell if triped but just push kinda like a house breaker but vertically
IMG_2491.jpeg

Also thinking back on my axis statement if you turn on the servos and they click and you try to move it but the servo doesnt strain and attempt to move then overtorques alarms out and shuts the servos back off its not a motion problem its something control… i replaced my z ballscrew and didnt line it properly and it wedged up and wouldnt move and thats how it will react
 
Also im troubleshooting a spindle vfd issue with uncommanded reverse rotation and I swapped phases at machine supply input and it just freaks the efff and and wont do anything iirc like control turns on but you get 15million alarms you have never seem so I doubt your out of phase… if you wanted we could face time, google duo or fb chat and I start my machine… it in the house garage and im just being lazy on the couch…
 
Update on what I have found

What was setting the 005 code looks to be a bad pressure switch on the way lube pump. I bypassed this for now and can get axis movement. I can also run the spindle.

I also ran into air pressure issue. Setting 002 alarm. I believe the issue is a bad pressure regulator. I was feeding it with 120psi air and even turning the regulator all the way up I could not get the air pressure switch to turn on (set to 0.4mpa). Anyway took the regulator out of the system for now and have my incoming air set to 75psi. All seems happy for now. I will get a FRL in the future to replace the one on the machine.

To those that mentioned the Mitsubishi VFD I am also getting an over-voltage alarm there. Hitting reset seems to clear that alarm and it doesnt show up again. The machine is 200-220volts per the tag. However the Mitsubishi vfd is tagged 200-230volts. I am guessing my 240+ is just a bit high for this VFD. If I have trouble in the future I may add a small transformer just for this VFD.

Now that I have axis movement I was able to zero all 3. I am getting stuck at tool changing. I was able to do a tool change (MDI T1M6, Tool 11 was in spindle). The machine did the change successfully. Now when I try another change (for instance T11M6) I get an alarm 007 which is basically invalid tool number. So I need to work out what is going on there. If anyone has thoughts please let me know.

I took all the way covers off, cleaned out all the swarf. Found the Y axis ballnut has a broken lube tube. Based on the amount of oil in the casting its been this way for a very long time. So I plan to fix that up and possibly replace the X axis tubes at the same time. The ballscrew visually looks good.

Making progress, thanks for all the help here!
 
Try calling the tool number on a line then M6 on the next line. You should transform your voltages to 200 for best results, this is what it probably is set to. Lots of oil everywhere is normal, I go through more way oil than coolant concentrate.

Is it the pressure switch or is it not building pressure on the lube pump? When I had problems with mine I got a pressure gauge for it. It's nice to see it build the 300 psi and hold it. You should go through your entire lube system and make sure all meters are working, way less work than fixing what isn't getting oiled down the road. One of the first things I would check is how perpendicular your spindle is to the table, head knod is an issue if it hasn't been maintained.
 
Ok experts, ballscrew/nut. Grease only?

Heres a video of what I see. I was surprised to see this. Maybe a replacement was installed and they went with sealed/grease version only? Also surprised they would just leave the oil line open into the base casting?

 
At least on mine on z it just drips way lube on the ball screw, not sure thats right but its the way it was
 
The Castor Oil Press is a powerful machine designed for extracting oil from castor seeds, known for their high oil content. This specialized press employs mechanical pressure to squeeze the oil out of the castor seeds, ensuring a thorough extraction process. The result is pure and high-quality castor oil, rich in beneficial properties. The Castor Oil Press is equipped with advanced features to optimize the extraction efficiency, making it an ideal choice for producers seeking top-notch castor oil for various applications. With its robust design and precision, this machine stands as a reliable companion in the journey from castor seeds to premium-grade castor oil.
 
Ok experts, ballscrew/nut. Grease only?

Heres a video of what I see. I was surprised to see this. Maybe a replacement was installed and they went with sealed/grease version only? Also surprised they would just leave the oil line open into the base casting?

I wonder what other fun stuff you will find...... no, that is not right. Someone will know that ballnut the glob of grease to me means they had a problem, squirted some shit in there, and made parts. I'd be checking backlash in several areas of that screw! It super annoys me because I bought a POS I never should have where I could hear the X make a touch more noise and no surprise, not a drop of oil making it to that screw!

You need to look that one over good!
 
Here is what I have found after more inspection and disassembly.

The oil line going into the base should have been going to the Y thrust bearing not the Y ballnut. I plan to pull that bearing out and inspect possibly replace.

The X and Y ballscrews have ports that just drip onto the screw. I dont know what Z looks like yet but wouldnt be surprised if this was the same. Not sure on the grease buildup but will need to measure lash on that screw. Now that I am into it further it is obvious that all of the oil piping needs to be replaced. Very brittle and alot of them broken.

So couple questions
Do I need to replace the distribution blocks also or just the tubing?
Where is the best source for this tubing, compression fitting, etc?
The flexible braided hose, replace these as well? Source for these?

Thanks for the help, getting deep into this machine more than I wanted but have to expect some issues on a 26 year old machine!
 
Distribution blocks have calibrated restrictors in them designed to apply lube in specified quantities. So these are staying unless you have full service manual for serivce tech.
 
As I learn more (lots of good info on the forum of course) the metering valves have larger numbers than what I was expecting. These are size 10, 20, 30. Does anyone have a way to reference these to more common dash sizes? I am working to get a parts manual for the machine but havent got it yet so poking around in the dark here.

As I wait for parts and work through what physically needs repaired on the machine I have also been learning the yasnac controller. I was working through tool offset and assigning tools to pot numbers in the carousel and found what I think is an issue. Might be what is causing the tool changer to not work as well.

Based on the manual I was expecting to see something similar to below (i randomly selected some tool numbers). With pot numbers from 1 up to the size of carousel in this case 20. Then the manual states to highlight the pot number and assign the tool in that pot i.e. highlight pot 6, type 14, WR. My machine however only shows one tool pot tp0001 and I am not able to write a tool to it (see photo). Does anyone know how to add tool pots to this list? Maybe there is something else I am overlooking? The tool offset page has a bunch of offset populated (from previous owner) and was able to overwrite these offset.

What I expected to see on TOOL POT SET screen
POT NO. TOOL NO.
tp0001 7
tp0002 4
.
.
.
tp0020 36

From yasnac manual
Capture.JPG
What I have (sorry for the bad photo couldnt get shutter speed and screen refresh to be happy)
IMG_6959.jpg
 
Ok I changed pm3001 digit 6 from word indication to byte indication. Now the machine shows 2 pots but I still can not WR tools to those pots.
Here is a photo of what I see now and a photo of my tool offsets (again these values are from previous owner but I can write to these)

IMG_6961.jpg

IMG_6962.jpg
 
My i80 does the same, only displaying tp0001, but it has no trouble keeping track of tool location in the carousel, I wouldn't worry too much about that until you're 100% sure you need those extra tp slots.
 
My i80 does the same, only displaying tp0001, but it has no trouble keeping track of tool location in the carousel, I wouldn't worry too much about that until you're 100% sure you need those extra tp slots.
Would love some education on your workflow in the i80. This is how I thought it worked based on reading the manual. But maybe I am misunderstanding how the controller works.

Say I have 16 tools
I would set tool offset for all 16 tools (it seems the machine can store up to 99)
H (D) 001 5.3
H (D) 002 6.1
.
.
.
H (D) 016 4.2

Then I would load those tools into the carousel and assign the specific tool to the POT number I loaded. POT numbers and tool numbers dont need to match.

Could be
POT NO TOOL NO
tp0001 8
tp0002 2
tp0003 16
etc.

Then in programing I would call the tool number (not the POT number)
i.e. T16
Machine knows T16 is in POT 0003.

Mind sharing how you do your tool offset and call tools in your gcode?

Thanks
 
Mind sharing how you do your tool offset and call tools in your gcode?

I'm lucky in that my entire body of work can be completed with about 10 different tools, so I rarely, if ever need to swap tools around so tomorrow I'll go take a look at the machine and remember how I normally go about setting tool numbers and take a look into the tool pot system on my controller.

As far as setting the tool offsets, I do it in a kind of backwards way opposed to how it should be done. If your machine is equipped with the tool length measurement feature, use that, this is how I do it, but refer to the manual for proper instructions.

Put a tool with a known offset into the spindle (this is unnecessary if you have your Bias properly set, see below)

(Record the known offset somewhere if you're doing my weird method)

Turn mode selection knob from MDI, Tape, etc. to any of the handle options, x1,x10,x100.

Depress the Tool length measurement button, which should bring up a screen with a crude diagram of the spindle and tool in the machine.

Set your Bias (this is where I vary from the manual, I rely on using a known tool offset to calculate another tool's offset because I couldn't make the tool length measurement work every time otherwise. This is something I've been meaning to look into but my method works perfectly every time so hard to break the habit.) in this case, mine is 2" because that's what my preset gauge is (this bias for my method is probably unnecessary but oh well it works).

Bring the tool down and make contact with the preset gauge (or reference plane if you don't have a preset gauge) you can move in all 3 axis in this mode, so don't worry if you have to move the table around.

Make sure the tool number you want to measure is highlighted and depress the Retract button to measure the offset (you may want to turn rapid down to 1%, I don't like having my gauge spring back so hard at 25 or 50%.)

Swap to another tool, bring down to gauge or reference plane, ensure the proper tool number is highlighted and depress the Retract button again to measure.

Depress the Tool length measurement button again to exit and be taken to the tool offset page.

If you're like me and too lazy to properly setup your bias, find the difference between your known offset and the new one just recorded, add that difference to the known tool offset to confirm you get the old, proper offset back. Then add that same difference to the newly measured tool, set the offsets for the tools to what you calculated/recorded from before. I know this method is not the proper way but it works every time for me no matter what fixture plate I have on the table at the moment.

For calling tools in the code, here's how it normally goes

%
O1001
(T01 D=0.5 CR=0. - ZMIN=2.5604 - FLAT END MILL)
(T05 D=0.3125 CR=0. TAPER=45DEG - ZMIN=2.8954 - CHAMFER MILL)
(T07 D=0.323 CR=0. TAPER=118DEG - ZMIN=2.3083 - DRILL)
(T08 D=0.25 CR=0. TAPER=118DEG - ZMIN=2.5902 - DRILL)
G90 G94 G17
G20
G00 G53 Z0.
(ADAPTIVE5)
M09
T01
G53Z0.M06
T07
...
X-10.4193 Y1.7457 Z3.0098
Y1.7454 Z3.0154
G00 Z4.1154
(DRILL5)
M09
M01
T07
G53Z0.M06
T08
S3547 M03
M08
G00 G54 X-9.7506 Y2.4624
...
rest of the program

T07 does get called twice before it actually gets changed to, but that's for redundancy and if you had to start from the DRILL5 op, you wouldn't have to do anything, just cut the code before hand and run it.
 








 
Back
Top