What's new
What's new

Program Stalling or Halting Randomly

FlyER2112

New member
Hello, I have a HAAS VF2SS that randomly stalls during program execution. I've been chasing this for a few months and wanted to share what I know before asking for help:
Sometimes wit will run for hours without halting/stalling. Other times, it will happen on every line. Cycle start will cause it to resume. Any other key will also cause it to resume most of the time (i.e. I can hit the up or down or right or left, or diag, or just about any button to get it to resume.
What does stall mean: It stops executing code and no motion is happening. Spindle and coolant remain on.
It will say "Waiting" on the lower right part of the display.

It's not acting like it's in single block as it will execute each part of the tool change macro / sequence per button press and return to waiting after each press of a button. In a single block a full tool cycle would happen. When it happens, it does not necessarily complete the full cycle as it will run each part of the tool change per button press.

This issue happens when running from Memory as I do not use RS232 for drip feed.

It can happen upon boot up or in the middle of a tool change, it can happen with a G01, G02, G03, or M28 (I assume it's not G-code or M-code dependent)

What have I tried:
1) I cleaned the Processor card in an ultrasonic cleaner as a first attempt to fix it in case it was related to dirt or some conductive material causing an interrupt or something on the processor card.
2) I paid HAAS to come and dump the processor memory (incase I had a memory area that was corrupt)
3) I had HAAS update the MOCON to the latest I could for that vintage.
4) I have tried code that is not High Speed machining ie just linear moves.
5) Not sure what to try next.

Year of MFG: 2004
SW Ver M13.18B, MOCON Version is 12.05.
I has done this off and on for the last two years but the last year it has been more frequent.
Sometimes, it goes away for a while when I shut it off and power it back up. Sometimes, it wants to be persistent and keep doing it.

I'd like to get this to be more stable and am open to any suggestions.
Thanks,
 

countryguy

New member
I would call the CA App team next. I've had good interactions with them when HFO did not (could not) solve/isolate.
 

EmanuelGoldstein

Active member
First thing I always do with intermittents is throw a scope across the power supplies. A
A meter will only tell you the voltage, not if it's clean or not.

Most likely won't solve the problem, too easy. But at least you will know that your processor power is clean and stable and the correct voltage. Check the foundation first.
 

beege

New member
Sometimes it's a corrupt offset table. Try this? Copy all of your tool and work offsets onto a piece of paper. Origin both tables (clear to zeroes everywhere). Re-enter the offsets manually. See if that fixes anything.
 

FlyER2112

New member
Great idea... I'll do that this Saturday - I'll respond with data from the following tests:
DC Supply voltages (Idle and while running)
I'll wire up a power resistor network to step the voltage down and will look at the noise on the VA-VB and VB-VC and VC to VA lines.
I'll also loo at the incoming voltages and outgoing voltages from my Rotary Phase converter. I'll also document my transformer tap configuration, and voltage sensor settings.
Thanks,
 

Mr.M

New member
Could it be there is an axis issue? Is there somewhere you can check to see if an axis is out of the "in-position" tolerance?
 








 
Top