What's new
What's new

Prototrak MX2 motor/encoding issue (video attatched)


Sep 21, 2022
Video of prototrak motor issue

Hello, looking for a prototrak guru out there that could shed some light on what could be going on with our Prototrak MX2 motor. We purchased this knee mill retrofit a month ago and everything was in working order, moved her into the shop and the Y axis is having a peculiar issue. I have attached a YouTube video with/without the belt on to help further illustrate the issue.

The issue is: whenever jogging or making a G1 move, any type of locomotion on the Y axis motor results in the motor ignoring its feed rate and rapiding at 120% for about 1 inch before reversing direction violently bouncing back and forth. So basically, the motor has no idea where it is. But the acurite picks this up and tells the computer about all this craziness (thru the DRO screen)

Machine information:
-1995 YCM-16VS (not really relevant but now we know the approx age of the Trak stuff)
-computer/motors are from May 1995 (happy birthday)
-position sensors are AcuRite Absolute Zero II scales / readers (glass)
-the X axis works perfectly fine
-nothing was smashed during the rig

Troubleshooting I’ve done so far:
-fully cleaned the glass scales, and removed reader from Y axis, cleaned and inspected, reinstalled (DRO/position reading never had any issues at all, very accurate)
-swapped the X and Y sensors on the back of the computer module just to see what would happen (both axis’ ran away but, important note, the Y motor was rapiding when it didn’t have Acurite telling it where its position was)
-issue persisted, so we stuck the Z axis reader on the Y axis scale, no luck (it’s still like this as the Z reader was in much nicer shape anyway)
-loosened the belt tension
-inspected motor amplifier for any damage
-inspected computer module for any blown fuses or anything out of the ordinary

Things we haven’t tried:
-swapping the working X motor onto the Y axis
-changing the glass scales
-haven’t tried any service codes/software related stuff

So we’ve tried most of the obvious things I think. That leads me to believe the encoder in the motor might be messed up? I really do not think the acurite sensors are the issue here after so much troubleshooting, and having a completely different reader on the Y now. And the glass I don’t believe to be an issue either. I know it’s really weird to have a SWI controller and motors and Acurite scales, but that’s how it always was and had been working fine up to this point.

If anyone out there has any ideas, or can pin down this issue to a specific part on the machine, that would be terrific. Very eager to learn more about this as the X axis will likely meet the same fate one day. Thank you!

Video of prototrak motor issue



  • IMG_3487.jpeg
    3.2 MB · Views: 2
  • IMG_3488.jpeg
    3.1 MB · Views: 2
  • IMG_3580.jpeg
    3.3 MB · Views: 2