What's new
What's new

Relay Signal Tracing on a Leadwell MCV-OP Machining Center

@dandrummerman21:

The relay board is a Leadwell -P100. I guess I could give COMPAT a call. Couldn't hurt.

I got around to replacing some LEDs. Once done, I could make every relay click that I replaced an LED for. Even got the carousel to move over by firing relay 16 with 24v.

Still can't get the control to move the carousel over with M21 or T2 M6. Also, when I turned on the machine after replacing the LEDs, one of them buzzed, flickered and went out. Testing with a meter found 120V AC on the coil. Turns out this coil (relay 21) was connected to the blown trace on the back of the board. I checked the burnt spot and found there was still a short. Some scraping fixed that.

IMG_0569 - Copy.JPEG

I think I finally have an idea why this board does not follow the diagrams. It appears to be an old version (following my diagram from 1991) that has been reworked to follow a newer version. (1995, see photo below.)

IMG_0572 - Copy.JPEG

I looked at my manual from 1995 and it lists a Fanuc model E3 I/O board. That is the type I have, though a different model number. At any rate, the more I test my relay board, the more I think that the mod's probably worked ok till that trace blew or some other fault that wiped out most of the relay LEDs. It also looks more clear that the I/O board on the control was also damaged and will not drive most of the relays anymore. I still need to find a good way to test that, but at this point it seems best to leave the relay board alone except fixing any stray voltages and what have you, and swap in a new I/O board.
 
What a mess.

I hope the machine itself didn't cost you much. The amount of effort going into fixing it is surely "costly" (even if you don't consider it money wasted). I also don't have much more to input other than, I hope you can get it sorted.

It really is the type of thing that you have to be there in person for.
 
Haha. It really is a mess. And the idea was to MAKE money with this thing. Maybe someday it will. If I can't get the tool changer working, I guess I'll just hand load tools and get on with life...

I see what your boos meant about high voltage on the relay board. There is 12V, 24V, 120V, and 220V all mixed together in a maze of traces. Even while being careful, I still caused an arc that may have damaged the 24V power supply. I've decided I'm not probing that mess anymore when the machine is on.

Thanks for all the replies guys. If folks are interested, I'll report back on what happens next.
 
I got the tool changer to work! A new Fanuc I/O board did the trick. 45 minutes of work and I was changing tools. There may be a couple LEDs that still need to be replaced to get all the relays working, but the kluged relay board seems to work ok. Thanks everyone for your help.

If the moderators see this, perhaps they could mark this tread as "solved".
 
So I assume the leadwell board took out the fanuc board. OR the fanuc board took out the leadwell board. Whichever.

Nice that it was a "simple" and "cheap" board to replace, instead of the leadwell one.
 








 
Back
Top