What's new
What's new

Rigid tapping on 15M Enshu

Your page describing the EX193 alarm says that input X20.5 is the spindle amp rigid tap ready signal while the page from the wiring diagram says it is input X0.2. This conflicting info makes troubleshooting a bit harder.

In your wiring diagram, find a Y address that is connected to a signal at the spindle drive labeled TLML and post a pic of that page.

Check that spindle drive parameter F31 is set to 1.
 
Vancbiker,
Here is the page. I’ll look into the spindle drive parameter tomorrow. Thank you for the help!
8d20a54842bc9b7caff18451e0895348.jpg
 
EX alarms are determined by the machine builder, not Fanuc. This tells me that you have not satisfied some requirement of the machine builder's implementation of rigid tapping. You need to refer to the machine builder's operation or programming manual to determine what is needed.

The 15M could do rigid tapping in IPR (G95) mode. Might give that a try, but I doubt it is the trouble. The builder might also have used an M-code (M29 is a code used by many builders) in their ladder program to set up rigid tapping. This is more likely IMO.


G84.2 is the old 15 format of rigid tap and generally does not need an M29
 
Vancbiker,
Here is the page. I’ll look into the spindle drive parameter tomorrow. Thank you for the help!.....

Ok, that shows the builder is using Y4.7 to tell the spindle to go into rigid tap mode. Next step is to look through the ladder program to figure out what conditions have to be met to turn on Y4.7.
 
Your ladder images show that F40.4 is off. F40.4 is the signal from the CNC to the PMC for rigid tapping mode. Were these images taken when the program had executed G84.2?
 
No, they were just taken with the machine doing nothing. I’ll try to get a look during the tap cycle.

Uuum, yeah. You know since we are trying to figure out a tapping issue, the machine should really be in tapping mode if possible. 🙄

Maybe I’ll go look for a wall to bang my head on......
 








 
Back
Top