What's new
What's new

T+ SQT18MS Sub Spindle Programming/Setup Help!

Tom3197

New member
Hey All,

I have a SQT18MS T+ machine that I'm trying to get the subspindle working on. We've had this machine for a while, but this is the first job that I'm using the sub for. (A multiplex ruins your use for a subspindle machine!)

I'm running a bar length in the spindle. When 1st OP is complete I want the sub to come up and grab the part, main spindle to unchuck, pull out a couple inches of bar, re chuck the main spindle, cutoff the part, then the sub with the part to go home and start machining the backside of the part. Simple right?

My program starts:
Pno 1: SEP unit, single head 1

1st OP machining

Pno 14: TRS BAR 1(setup) 2(head) 0(spindle off)

Pno 15: TRS BAR 2(setup) 1(head) 0(spindle off)

Pno 16: SEP SYNC

Pno 17: GRV OUT cutoff unit

Pno 18: TRS MOV 3(setup)

Pno 19: SEP unit, Single Head 2

2nd OP machining

End.

Now when I run my program it completes the 1st OP, the tool goes to the Tool Change Position (X home), The subspindle doesn't move, but the jaws clamp, and then I get a spindle alarm.4E flashes on the spindle drive. Both spindles operate just fine independently. If you go to Handle and put the machine in LINKED MODE, both spindles mirror each others movements as they should (Main: Master , Sub: Slave). I cut my jaws on the sub, so I know it works...

Any advice on why this isn't working for me? I'm trying to do a BAR LOOP and SUB SPINDLE MOVE... I *think* I've followed mazak's directions correctly on all the transfer setup... any ideas?

I talked to someone with a similar machine except it was a T32 and they said I didn't need the 2nd TRS BAR unit (Pno 15)... I just have no idea here.:confused:

Does anyone have a T+ machine and a program that is basically trying to do the same thing I'm doing? Would you share a program with me?
 

Dave Cross

New member
Hey Tom, sorry it took me so long to get back to you. Here are some snippets from a program for my t32-3 with sub spindle:

DSC_0027.jpgDSC_0028.jpgDSC_0029.jpgDSC_0030.jpgDSC_0031.jpg
 

Dave Cross

New member
So the differences I see between my program and yours is:

-I used a MNP process before your Pno 14
-On your Pn015, I had an extra setting for "chuck" which I set to 1
-On your Pno16, what are your settings for "head" and "spindle"?
-On your Pno 17 I used a mnp process instead of grv out.

Its been a couple years or more since I made that program, but it works, and works well. I did it before I was able to get the sub spindle manuals so it might not be Mazak Kosher but I've since copied and pasted it into other programs with no ill effects.

I'd be curious to see what your setup data looks like.
 

Tom3197

New member
Got it figured out. It needed the M5 spindle stop before the transfer unit. Sometimes mazatrol is really smart, other times its really stupid! So after seeing your program with an M5 I gave it a shot and it fixed all my issues. But none of my other mazak supplied programming examples show the need for it... shocking right...
 
Last edited:

ME Newb

New member
I apologize for resurrecting an old thread. This has helped me a lot but I still need some info.

I do not have my bar feeder going yet so I'm going to pull with the sub. Where do I need to put the TRS MOV process to pull the bar before cutoff? Also would like an example of the transfer setup numbers if possible. Part length is .925, cutoff .161.

Right now I have:
Pno 1 - SEP SIN head 1

Pno 14 M1, M5, M358
Pno 15 - TRS BAR setup 1, head 2
Pno 16 - TRS MOV setup 2
Pno 17 - TRS BAR setup 3, head 1
Pno 18 - SEP SYNC 1
Pno 19 - SEP SYNC 2

Does this look right?
 

will_0000

New member
I don't know if these are any help to you but they describe the sub-spindle options along with a programming example for pulling and cutting off.

001.jpg
002.jpg
003.jpg
005.jpg
004.jpg
 








 
Top