What's new
What's new

Tree 2uvr head stud pull-through repair options?

rusttick

Plastic
Joined
Jun 21, 2021
2uvr_head_bolt_pull_through_small.jpg2uvr_head_bolt_closeup_small.jpg

Hello There!

This is a Tree 2uvr I am attempting to reassemble after cleaning and replacing belts.
This stud is pulling through as I tighten the nut.
There was no build up and release of tension or snap of any kind when tightening.
The stud has not rotated and does not appear bent, stretched, or otherwise deformed.
The feel when tightening is that of stripped threads pulling through.

What could be on the other end of the stud?
Recommendations?
I am new to the forum. Am I posting correctly?

Thanks so much for your time!
 

4GSR

Diamond
Joined
Jan 25, 2005
Location
Victoria, Texas, USA
Don't have any experience with Tree heads. Common sense should tell you exactly what you have said, the threads have more than likely stripped out from a previous "Bubba" experience. At minimum, you are going to have to tear down the upper half of the mill head to get to the problem. Then a plan of attack on how to fix it would be next.
Keep us posted on what you find.
Ken
 

rusttick

Plastic
Joined
Jun 21, 2021
inside_head_casting.png


Hi Ken! Thanks!

Here is a photo of the inside the head casting (not mine) https://flic.kr/p/eAJHS8 That should be where the stud is attached.

I don't think I'll see anything different.

I wanted to check on the forum first because, in theory anyway, there are multiple ways the stud could be attached: cast-in-place, glued in, interference fit, etc... I'm probably overthinking it, so I'll proceed assuming the casting is drilled and tapped for the stud.

I'll try to unscrew it from the casting next.

Thanks again!
 

rusttick

Plastic
Joined
Jun 21, 2021
tree_threads_small.jpg

I overthought it.

Pulling it straight out took care of drilling for a 3/8-16 tap.
Tapped... and turning a new stud to match.

Thanks again!
 








 
Top