BridgePort to Pc Connection
Close
Login to Your Account
Page 1 of 2 12 LastLast
Results 1 to 20 of 31
  1. #1
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default BridgePort to Pc Connection

    Hi this has probably been asked before but can someone help me with connecting my BP series 1 MKll to my pc which the OS is windows XP Pro 64bit when i try to send from the Mill it says (EXT IN-/OUTPUT NOT READY.
    Any help would be greatly appreciated .

  2. #2
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    You need to list the control to get help

    It is a Heidenhain

    Do you have a serial port or a USB emulator

    Do you have remontpc? It has to be on and ready to send or receive before pushing the button on the machine

    I have successfully run a cheap emulator on a little XP notebook. I have the emulator, adapter 9-25 pin, connection box with jumpers[I believe it is 'null modem' and may not actually be required] then 25 pin cable

  3. #3
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Cheers for the reply
    It is a Heidenhain YES IT IS A 150.

    Do you have a serial port YES IT IS A SERIAL PORT.

    Do you have remontpc NOT SURE WHAT THIS IS.

    I have a 25pin to 9 pin adapter then a 9 pin serial cable
    and i run Hyperterminal.
    hope this is a bit more help.

  4. #4
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    Quote Originally Posted by gixer View Post
    Cheers for the reply
    It is a Heidenhain YES IT IS A 150.

    Do you have a serial port YES IT IS A SERIAL PORT.

    Do you have remontpc NOT SURE WHAT THIS IS.

    I have a 25pin to 9 pin adapter then a 9 pin serial cable
    and i run Hyperterminal.
    hope this is a bit more help.
    Then either download remontpc from heidenhain website or get the settings correct in hyperterminal

    from memory, someone help me out....

    2400 baud, 1 stop bit, even parity, no flow control

  5. #5
    Join Date
    Aug 2019
    Country
    UNITED STATES
    State/Province
    Texas
    Posts
    118
    Post Thanks / Like
    Likes (Given)
    15
    Likes (Received)
    17

    Default

    Baud, stp, parity... that brings back a lot of memories trying to hook up anything to an older computer.

  6. #6
    Join Date
    Mar 2009
    Country
    UNITED STATES
    State/Province
    California
    Posts
    5,602
    Post Thanks / Like
    Likes (Given)
    103
    Likes (Received)
    1084

    Default

    Windows XP-64 is a free version which was not supported.

    Is this the location for that "remontpc" software?

    PC software and manuals

  7. #7
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    I`ve changed now to windows 10 and installed TNCremon which puts up an error no responce from TNC so i think it might be the cable so i`ll sort another cable and try that.

  8. #8
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    fire up tncremo

    start tncserver within it

    change the settings so that the baud rate is correct

    connect the cable if it isnt

    write a little program in the machine

    set the software to receive and start


    try to send the program

  9. #9
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Hi i`ve tried different options and still can`t get them to communicate with each other is there a certain pin out on the serial cable it shows a few different types in the Tnc software would anyone know which is the correct one for the TNC150 cheers.

  10. #10
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    I`ve checked my cable and that seems to be ok if i try to establish connection it comes up with No Response from TNC is there anyway i can check the serial at the Tnc.

  11. #11
    Join Date
    May 2009
    Location
    San Jose, CA
    Posts
    198
    Post Thanks / Like
    Likes (Given)
    274
    Likes (Received)
    236

    Default

    In the old days, with 25 pin RS232 connectors (PC serial data), there were handshaking lines RTS and CTS, and possibly another (memory shorting out...). In more recent times, the communications chips became more sophisticated and these lines are generally not necessary. It is standard practice these days to only have 3 lines connected between the serial ports: a Ground wire, A Data IN wire, and a Data OUT wire. If you hook up an old device to a modern computer, the computer may not be using the old handshaking lines by default, while the external device may require them. A cable between the device and the computer may have the lines connected to the pins, but if the handshaking protocols are necessary but not enabled, then the external device will not be able to respond.

    What I am describing is a generic issue for serial communications. I have no direct knowledge if this applies to your situation, but if the Heidenhain box is old, it very well might. If you can find a manual for the Heidenhain box there is a chance that it will show the serial port output terminals. If so, check if RTS, CTS, and any other handshaking lines are mentioned. If they ARE, you may have to find a way to enable them on the PC that you are using to communicate with it.

    Hope it helps. Best wishes,
    Michael

  12. Likes Scottl liked this post
  13. #12
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    OK cheers i`ll have to look into it i use to do a lot with serial over 25 years ago but can`t really remember much of it now.

  14. #13
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Is it possible the software for the tnc has got corrupt as it just keeps saying EXT IN-/OUTPUT NOT READY i tried a loopback test and that was the same result.

  15. #14
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Hi iv`e finally got the PC communicating with the TNC 150 the problem i have now is when i send a program from the pc to the TNC nothing appears on the TNC screen but if i send a program from the TNC to the PC it sends ok and saves it to the PC any help would be appreciated .All so does anyone know how to setup the drip feed.
    Cheers

  16. #15
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    Ok, so you know your baud rate etc is correct

    What program did you end up using?

    If it is TNCremot and it is just hanging, try different import routines.

    read in program offered or read in all programs

    there is a certain order of doing things that is not obvious but which makes a difference
    also send the program you just exported to make sure it is a good program

  17. #16
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    OK i think i`ve sorted it now i can upload and download all the programs i have in the TNC.The program i was trying to upload was in the wrong code i think, can i convert programs i do with fusion 360 to upload to the TNC.
    Cheers for your help so far.

  18. #17
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    OK so i have another problem now.I can download & upload programs that are on my mill But i can`t upload any programs i make on fusion360 i`ve tried different versions of HeidenHain if i do it in ISO i can see it uploading from the PC server but thats it nothing on the mills TNC if i try it in another format eg (.i .h )i don`t see anything appear it just shows <ETX> on the server screen.Anyone got any ideas.

  19. #18
    Join Date
    Apr 2020
    Country
    UNITED KINGDOM
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    I`ve found out with some digging i can`t Dripfeed on my Tnc 150b because my parameters only go upto MP214 is there anyway i can upgrade the eprom to another version to accept drip feed.

  20. #19
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    Post the beginning of the program from fusion
    I had to rip a bunch out of the post to make it load in my 151

  21. #20
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    4,461
    Post Thanks / Like
    Likes (Given)
    434
    Likes (Received)
    2711

    Default

    pgm name needs to be numbers only

    no block form
    machine needs to be set for ISO if ISO pgm IIRC
    R


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •