EZ Trak Emergency Stop
Close
Login to Your Account
Likes Likes:  0
Results 1 to 3 of 3
  1. #1
    Join Date
    May 2010
    Location
    Missouri USA
    Posts
    6
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default EZ Trak Emergency Stop

    I recently purchased, what should be about a 2000 3-axis EZ Trak mill that has been setting for a several years. The machine powers up and completes the BMDC test but I cannot clear the E-Stop Alarm. The E-Stop button on the Operators Control works. The oil reservoir is full. Motor Overload isn't tripped. I've got a few other EZ Traks that I have had for about 15 years so I know my way around these machines pretty well. This one has me stumped though. I had to top off the oil reservoir before firing it up so i'm a little concerned that the Lube Level switch may not be closing. Can anyone give me some guidance on checking it or some other area that I may be overlooking? I've attached images of the BMDC card just in case I missed something on the indicator lights.img_9596.jpgimg_9597.jpg

  2. #2
    Join Date
    Dec 2013
    Location
    Fort Wayne, IN
    Posts
    787
    Post Thanks / Like
    Likes (Given)
    827
    Likes (Received)
    277

    Default

    There should be a few circuit breakers on the right hand side of the control cabinet. Flip them all off then back on again. Does that fix it? My next guess would be wiring in the little panel to the left of the head has a loose wire, if the switch is functioning properly.

    As I look at the picture more, I am curious. There is only one cable going from the BMDC to the BOB card. On a non-CIB Trak, one cable goes from the BMDC to the AXSBOB and one goes from the BMDC to the AUXBOB. It has been a while, but I am 99% sure that there should be a second cable going from the BMDC to the BOB card to the right of it.

    Are any of your other Traks the CIB like this one for you to look at?

    Jon

  3. #3
    Join Date
    Dec 2013
    Location
    Fort Wayne, IN
    Posts
    787
    Post Thanks / Like
    Likes (Given)
    827
    Likes (Received)
    277

    Default

    Ya, that connector that is blank is the connector that would be connecting to the AUXBOB that reads the E stop circuit. So your BMDC is just seeing an open on the E stop circuit and wont clear. Once you get that cable, you should be able to get further along in the process.

    Jon


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •