G2 and G3
Close
Login to Your Account
Likes Likes:  0
Results 1 to 3 of 3

Thread: G2 and G3

  1. #1
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    Missouri
    Posts
    210
    Post Thanks / Like
    Likes (Given)
    59
    Likes (Received)
    46

    Default G2 and G3

    I have a Tsugami swiss here. We bought it new a few years ago. It is my first swiss experience.
    I generate toolpaths for it out of Mastercam using the same post I use for subspindle lathes.

    The issue I have is, even though I can get the correct axis combinations using upper lower turrets and subpindle. This machine, and I dont know if this is common to all swiss lathes. The ccw and cw arcs are different for different tool positions. Even with the same axis directions (ie X+dia Z+ into the part).


    Is this something that could be done in the machine def or post? Where on tools 1-9 G2 is cw and 10-27 G2 is ccw?


    I and just guessing, but I think this comes from Tsugami setting up the control so tools on both sides of the gang use X+. It inverts the axis direction based on active tool but not the arc direction.

  2. #2
    Join Date
    Nov 2014
    Country
    UNITED STATES
    State/Province
    Florida
    Posts
    4,549
    Post Thanks / Like
    Likes (Given)
    1745
    Likes (Received)
    2180

    Default

    Quote Originally Posted by GENERALDISARRAY View Post
    I have a Tsugami swiss here. We bought it new a few years ago. It is my first swiss experience.
    I generate toolpaths for it out of Mastercam using the same post I use for subspindle lathes.

    The issue I have is, even though I can get the correct axis combinations using upper lower turrets and subpindle. This machine, and I dont know if this is common to all swiss lathes. The ccw and cw arcs are different for different tool positions. Even with the same axis directions (ie X+dia Z+ into the part).


    Is this something that could be done in the machine def or post? Where on tools 1-9 G2 is cw and 10-27 G2 is ccw?


    I and just guessing, but I think this comes from Tsugami setting up the control so tools on both sides of the gang use X+. It inverts the axis direction based on active tool but not the arc direction.
    I don't know anything about your machine, but I ran a milltronics that was goofy on turning rads too. It's been a while, but maybe I had the tool setup wrong in Mastercam. Have you done anything on that page? "Reverse" the tools on one side. So one is facing up and one down and 180? I don't know if that will do what you need, or you already have that set....

  3. #3
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    Missouri
    Posts
    210
    Post Thanks / Like
    Likes (Given)
    59
    Likes (Received)
    46

    Default

    Mike
    yeah I have tried every configuration. I use the "setup tools" page on the regular to allow use of tools on subside. It only allows use on the second spindle and changes spindle direction. Axes signs are controlled by the axis combo and the arc directions are tied to that. I think.

    My reseller says they have a post that "might" work. but after I gave them a proven pair of programs they went radio silent.



    A friend of mine has a good idea. Setup a post with MI switches to invert the G2 and G3 at will, I wonder if thats possible to do?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •