Mastercam maintenance increase - Page 3
Close
Login to Your Account
Page 3 of 3 FirstFirst 123
Results 41 to 50 of 50
  1. #41
    Join Date
    Jun 2012
    Location
    Michigan
    Posts
    4,567
    Post Thanks / Like
    Likes (Given)
    4167
    Likes (Received)
    2723

    Default

    Quote Originally Posted by 316head View Post
    2020 is definitely not that great and the core problems still persist.
    What core problems are you referring to?

  2. #42
    Join Date
    Apr 2006
    Location
    Ga.
    Posts
    130
    Post Thanks / Like
    Likes (Given)
    9
    Likes (Received)
    12

    Default

    I run 2020 all day and it runs pretty damn good for me.

  3. Likes Mtndew liked this post
  4. #43
    Join Date
    Jun 2012
    Location
    Michigan
    Posts
    4,567
    Post Thanks / Like
    Likes (Given)
    4167
    Likes (Received)
    2723

    Default

    Quote Originally Posted by rickyt View Post
    I run 2020 all day and it runs pretty damn good for me.
    Same here, only 1 crash in the last couple of months that I've been using it daily.
    It seems more stable than 2019 in that regard. I've dubbed 2019 Crashtercam.

  5. Likes dodgin liked this post
  6. #44
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    California
    Posts
    56
    Post Thanks / Like
    Likes (Given)
    33
    Likes (Received)
    33

    Default

    Upgraded for 3 years and got a 15% discount....comes out to about $100/month.

  7. #45
    Join Date
    Feb 2018
    Country
    DENMARK
    Posts
    159
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    118

    Default

    I am a old mastercam guy. Used mastercam for alot of years up to x6.

    Been using inventor hsm for a few years and I like it.


    But comparing these twos you cant.

    Inventor hsm does the job for me but I still loved the workflow in mcx.

    I don't do much cad

    Sendt fra min EML-L29 med Tapatalk

  8. #46
    Join Date
    Jul 2006
    Location
    EU
    Posts
    12
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Our maintenance cost increased 60%
    We have Mill, Mill 3d, lathe and lathe entry licenses.
    We are looking other options now

  9. #47
    Join Date
    Jun 2006
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    1,870
    Post Thanks / Like
    Likes (Given)
    1082
    Likes (Received)
    734

    Default

    Quote Originally Posted by Mtndew View Post
    Same here, only 1 crash in the last couple of months that I've been using it daily.
    It seems more stable than 2019 in that regard. I've dubbed 2019 Crashtercam.
    MC 2020 killed a part for me yesterday. Not in Backplot or Verify. Sent the tool straight through a wall.

    The only way I can run a Dynamic path now is to check Full Vertical Retract.

  10. #48
    Join Date
    Jun 2012
    Location
    Michigan
    Posts
    4,567
    Post Thanks / Like
    Likes (Given)
    4167
    Likes (Received)
    2723

    Default

    Quote Originally Posted by Rstewart View Post
    MC 2020 killed a part for me yesterday. Not in Backplot or Verify. Sent the tool straight through a wall.

    The only way I can run a Dynamic path now is to check Full Vertical Retract.
    I was referring to software crashes.
    Machine crashes if/when they happen are my fault, unless an operator fucked up by editing the program.

  11. #49
    Join Date
    Nov 2007
    Location
    canada
    Posts
    702
    Post Thanks / Like
    Likes (Given)
    92
    Likes (Received)
    375

    Default

    Quote Originally Posted by Rstewart View Post
    MC 2020 killed a part for me yesterday. Not in Backplot or Verify. Sent the tool straight through a wall.

    The only way I can run a Dynamic path now is to check Full Vertical Retract.
    Those dogleg rapids will get you every time. Not the softwares fault, either setup Mastercam correctly to simulate doglegs or setup your machine to not rapid with doglegs.

  12. Likes rickyt liked this post
  13. #50
    Join Date
    Sep 2018
    Country
    UNITED STATES
    State/Province
    Arizona
    Posts
    12
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    4

    Default

    Quote Originally Posted by goooose View Post
    Those dogleg rapids will get you every time. Not the softwares fault, either setup Mastercam correctly to simulate doglegs or setup your machine to not rapid with doglegs.
    Basically this. FeatureCam will do this too.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •