SolidWorks Coordinate system issues
Close
Login to Your Account
Results 1 to 9 of 9
  1. #1
    Join Date
    Aug 2019
    Country
    CANADA
    State/Province
    British Columbia
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default SolidWorks Coordinate system issues

    I'm using solidWorks 2018 with HSM works CAM, and i'm unable to select the lines or vertex of my sketch when trying to use it to create a coordinate system. I'm not the most proficient with the software but i've checked all the filters as well as restarted whenever i've ran into the problem. Not to sure what more i can try.

  2. #2
    Join Date
    Nov 2010
    Country
    UNITED KINGDOM
    Posts
    58
    Post Thanks / Like
    Likes (Given)
    13
    Likes (Received)
    8

    Default

    You can create a co-ordinate system in Solidworks and you can select it in HSMworks. It's somewhere under insert and then reference geometry from what I remember and then you select it as the coordinate system when you set up the job.

    You could also try adding a point where you want the coordinate system to be and see if it lets you select that.

  3. #3
    Join Date
    Aug 2019
    Country
    CANADA
    State/Province
    British Columbia
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Yeah I've been using "coordinate systems" under the reference geometry tab. It only lets me select geometry of the model itself. But i need my datum to be above my chamfer so i sketched a couple of lines col-linear to the X & Y. This method usually works but lately it hasn't been.

  4. #4
    Join Date
    Dec 2014
    Country
    CANADA
    State/Province
    British Columbia
    Posts
    1,280
    Post Thanks / Like
    Likes (Given)
    361
    Likes (Received)
    585

    Default

    Create a 3d sketch and insert planes referencing that and see if that works.

  5. Likes Veteran Bicycle liked this post
  6. #5
    Join Date
    Jan 2016
    Country
    UNITED STATES
    State/Province
    New Jersey
    Posts
    216
    Post Thanks / Like
    Likes (Given)
    66
    Likes (Received)
    95

    Default

    I'm using 2019, but I have no issues selecting sketch geometry as a reference. Maybe some pictures or a video would help clear it up.

  7. #6
    Join Date
    Nov 2010
    Country
    UNITED KINGDOM
    Posts
    58
    Post Thanks / Like
    Likes (Given)
    13
    Likes (Received)
    8

    Default

    Quote Originally Posted by Chase_0893 View Post
    Yeah I've been using "coordinate systems" under the reference geometry tab. It only lets me select geometry of the model itself. But i need my datum to be above my chamfer so i sketched a couple of lines col-linear to the X & Y. This method usually works but lately it hasn't been.
    Insert a plane at the correct height and then project the point and put the coordinate system onto that? There are probably loads of ways of doing it but it sounds like there is a preference that has changed or been corrupted. If you use Regedit you can rename the old preference file and it will create a new one on startup but you will loose any customisations.

  8. #7
    Join Date
    Nov 2007
    Location
    Hamilton, Ontario
    Posts
    1,099
    Post Thanks / Like
    Likes (Given)
    801
    Likes (Received)
    422

    Default

    If you can't pick on the sketch it may be because you still have the sketch open. Make sure you close the sketch before starting to apply the coordinate system.

  9. #8
    Join Date
    Oct 2013
    Country
    UNITED STATES
    State/Province
    Arkansas
    Posts
    186
    Post Thanks / Like
    Likes (Given)
    54
    Likes (Received)
    15

    Default

    Quote Originally Posted by Chase_0893 View Post
    I'm using solidWorks 2018 with HSM works CAM, and i'm unable to select the lines or vertex of my sketch when trying to use it to create a coordinate system. I'm not the most proficient with the software but i've checked all the filters as well as restarted whenever i've ran into the problem. Not to sure what more i can try.
    I am on 2019, but otherwise we have identical setups.

    I use points in a 3D sketch to set my work coordinate systems. I constrain to "on plane" unless there is some reason not to, and in that case a construction line to whatever geometry I need. This is for machining to fixtures using their actual geometry instead of their CAD geometry. I used it recently to machine a mold half that was on the table crooked with no practical way to align it to any axis. I calculated the angle and put an infinite line at the angle to simulate the X-axis and ran the toolpath. I couldn't use G68 because HSM calls planes during some linking moves and I wasn't in the mood to bother.

    I suspect you are trying to select the line through a solid, probably if it's transparent - because you can see the lines but you can't touch them! I usually create a solid for stock and make it transparent.

  10. #9
    Join Date
    Aug 2019
    Country
    UNITED STATES
    State/Province
    New Jersey
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    3
    Likes (Received)
    2

    Default

    Ive seen this issue when the graphics card is working overtime. Do you have anything else running? Half of all the issues I see with selecting edges or surfaces in Solidworks are due to me running youtube, email, 3 browsers, and 12 assembly files open.

  11. Likes len_1962 liked this post

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •