TNC151 Dripfeed tool definition problems
Close
Login to Your Account
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2017
    Country
    UNITED KINGDOM
    Posts
    35
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    6

    Default TNC151 Dripfeed tool definition problems

    Hello All,

    I know this control is old but hoping somebody can help please. I have finally got my bridgeport interact 1 connected to PC and using Fusion 360 fro CAD/CAM and using their TNC155 post processor.

    I have had some programmes running drip feed but tried to run one today and it keeps stopping on the fault I have shown in picture img_2515.jpg

    All the tool definitions are in the lines above this in the correct place which makes me wonder if it looks elsewhere for tool definitions when drip feeding?

    It states in manual that it looks for tool offsets in the tool library during drip feed blockwise transfer.

    I cannot for the life of me find the library in the control. I tried calling tool 0 in programming mode but it lets me call tool and thats it.

    It seems some tools work and some don't so I'm wondering if definitions are stored for other tools somewhere in my memory ad its using those.

    EDIT: I have read that during drip feed the 151 controller doesn't remember the tool definitions so it works if one line of tool refs but not multiple lines. Anyone know if this is the case please?

    Many thanks

    Colin

  2. #2
    Join Date
    Jan 2003
    Location
    UK
    Posts
    867
    Post Thanks / Like
    Likes (Given)
    452
    Likes (Received)
    435

    Default

    Tool table should be up as Program #0 with offsets for each tool.

    There is a parameter to set that defines how many tools in the table.

  3. #3
    Join Date
    Mar 2017
    Country
    UNITED KINGDOM
    Posts
    35
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    6

    Default

    Quote Originally Posted by andrewmawson View Post
    Tool table should be up as Program #0 with offsets for each tool.

    There is a parameter to set that defines how many tools in the table.
    Thanks Andrew, so a simple program nbr push and call program 0 in edit? I will try that again tomorrow.

    I am told that in drip feed the controller doesn't remember the tool defs at beginning of program so I'm hoping that doing a call next tool might help.

    Cheers,

    Colin

  4. #4
    Join Date
    Dec 2012
    Location
    ny usa
    Posts
    419
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    257

    Default

    Parameter 225 is the central tool memory. Values are 0-99. You then enter tool def. using program 0.

  5. #5
    Join Date
    Mar 2017
    Country
    UNITED KINGDOM
    Posts
    35
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    6

    Default

    Quote Originally Posted by woodsrider845 View Post
    Parameter 225 is the central tool memory. Values are 0-99. You then enter tool def. using program 0.
    Thank you for that information. I have found the issue with program was that in drip feed mode the tool def at start of program are ditched by program to make room so aren't there when needed.

    I have got round it by adding tool def above tool call by manual pass through in Fusion.

    If I can get tool store working then that will be much better.

  6. #6
    Join Date
    Mar 2017
    Country
    UNITED KINGDOM
    Posts
    35
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    6

    Default

    Quote Originally Posted by woodsrider845 View Post
    Parameter 225 is the central tool memory. Values are 0-99. You then enter tool def. using program 0.
    I have now activated the tool emery and now have a 99 tool memory so very happy. Just need to check the drip-feed calls from this now.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •