2002 Haas VF4 Tool changer issue?
Close
Login to Your Account
Likes Likes:  0
Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2021
    Country
    UNITED STATES
    State/Province
    Arkansas
    Posts
    3
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default 2002 Haas VF4 Tool changer issue?

    We recently bought a 2002 Haas VF4. We got it from a industrial liquidator that buys whole plants and sells the contents. So they have no knowledge about the machine.

    I just got it under power and have been having some issues with it. First, the gearbox wouldn't shift from high to low, I think I have this fixed now (hopefully).

    Now, I got it to power-up/restart, it homes the table and Z and the tool changer homes to tool 1. If I try and do a tool change either in mdi with the ATC fwd/rev or with M6 it says "No tool home".
    Now this is where I get lost. If I go to hand jog, I can move the Z and X Axis but when I hit the Y axis button it says "Shuttle in" and I cant move it. I can however write a program in mdi and move the Y axis that way.

    Neither the no tool home or shuttle in are alarms either just was pops up on the controller.

    So what the heck is Shuttle in? and what exactly does No tool home mean? I have tried talking to Haas and he was just as confused as I was.

    Any help would be greatly appreciated.


    EDIT: forgot to mention it has a side mount tool changer, 24 tool.
    Last edited by cmiles; 04-07-2021 at 09:45 AM.

  2. #2
    Join Date
    Sep 2015
    Country
    UNITED STATES
    State/Province
    Ohio
    Posts
    1,697
    Post Thanks / Like
    Likes (Given)
    1127
    Likes (Received)
    1759

  3. #3
    Join Date
    Apr 2021
    Country
    UNITED STATES
    State/Province
    Arkansas
    Posts
    3
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Sorry, I forgot to mention, its a side mount tool changer. No luck with any of the tool changer trouble shooting guilds Ive seen...

  4. #4
    Join Date
    Sep 2015
    Country
    UNITED STATES
    State/Province
    Ohio
    Posts
    1,697
    Post Thanks / Like
    Likes (Given)
    1127
    Likes (Received)
    1759

    Default

    The only thing I can think of off-hand is on the tool pocket table. Is there a tool 1 in there? What tool is in the spindle?
    My Haas doesn't like T0.

    Instead of T2 > ATC Forward, try P2 > ATC forward. That will toolchange to whatever is in pot 2.

  5. #5
    Join Date
    Apr 2021
    Country
    UNITED STATES
    State/Province
    Arkansas
    Posts
    3
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    So I talked with my local Haas dealer. The tech said he thinks the machine thinks it has a umbrella tool changer not a side mount... So he wants to have a tech come out a flash the software. $1500... not sure there is anyway around that. Why and how would it not know it was a side mount tool changer?

    One thing I did do was swap the pocket door sensors and that made the shuttle in message go away and I can move the Y axis in hand jog. But if Im being honest I'm a little nervous about trying to do I tool change without knowing what it will do. I guess Ill have to cough up the money and have them come out...

  6. #6
    Join Date
    Jul 2006
    Location
    Hillsboro, New Hampshire
    Posts
    12,517
    Post Thanks / Like
    Likes (Given)
    2857
    Likes (Received)
    8697

    Default

    Get some guarantee that you'll recoup some of that money if the reflash doesn't fix the problem and you need additional tech time.

    Also, the reflash will likely take away the option for you to run the machine with the doors open, if that matters to you.

  7. #7
    Join Date
    Feb 2007
    Location
    Rhode Island, USA
    Posts
    602
    Post Thanks / Like
    Likes (Given)
    14
    Likes (Received)
    97

    Default

    Did you check the phase rotation of the incoming power? I think there is a set of neon lamps on the board to the left of the incoming breaker that shows proper rotation. If not you can use the coolant pump or chip auger?

    Been a while since I have worked on a VF with a side mount tool changer so I can't say if there are simple 3 phase AC motors in the tool changer. If there are and the rotation is wrong it may run the carousel and/or the tool arm backwards which will confuse the control.

    Before you call the tech in look through any documentation you have for the machine, including on the inside of the electrical panel door for a copy of the parameters. You can easily verify if the parameters are correct if you have that documentation, even if you need a little guidance from this forum.
    Last edited by Pipes; 04-18-2021 at 06:17 AM.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •