Desperate need of help! TNC 407
Close
Login to Your Account
Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2016
    Country
    ROMANIA
    Posts
    14
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    2

    Question Desperate need of help! TNC 407

    Hi guys! My boss bought from an auction this machine Mikron WF51 D with TNC 407 opperating sistem and we have some issues with this old lady...
    When trying to pass referince points after pressing FEED ON button, for example holding -Z axis on the screen apears a numerical value of F (ex. F500) for about 5 secounds and after the value disapears and the axis will not move in all that time and in the lower left side of the screen the "*" (star) remains active wich indicates that axis is moving. So nothing happens and no error apears...but after all of that if I press MANUAL button it activates emergency stop and I recive an error "13 FEED DRIVE NOT READY".
    Any solutions, guys...? I should try to make a video and be more explicit!
    Any help should be so, so welcome!

  2. #2
    Join Date
    Jul 2016
    Country
    ROMANIA
    Posts
    14
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    2

    Default

    The video as I was saying is here:

    YouTube

    If there is anyone who can help me I would be so grateful.

  3. #3
    Join Date
    Jun 2015
    Country
    UNITED STATES
    State/Province
    Colorado
    Posts
    377
    Post Thanks / Like
    Likes (Given)
    861
    Likes (Received)
    143

    Default

    On my TNC355 you press the power button again for each axis to pass over reference marks, not the actual jog controls.

  4. #4
    Join Date
    Jan 2005
    Location
    The Netherlands
    Posts
    5,633
    Post Thanks / Like
    Likes (Given)
    252
    Likes (Received)
    1407

    Default

    Manuals and more for TNC controls can be found on the Heidenhain website
    The older ones are hard to find (Even a search will not find them )
    Here is a link
    Home: Software - HEIDENHAIN
    Click on "cnc controls"
    Click on "Others" for more controls
    Click on the controle you are looking for
    Then click on the documentations PDF file you need
    The download button appears just below the picture
    I hope this helps
    Peter

  5. #5
    Join Date
    Jul 2016
    Country
    ROMANIA
    Posts
    14
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    2

    Default

    Thanks guys for replyes, let's take in order, on TNC 407 you cand press or the axis button or the Cycle in order to travers reference points. I've been there, on Haidenhain website and download the manuals for several controls (407/155/Plus) during last 6 years since I started machining parts bouth service manuals and operating manual and nothing about this "13 Feed Drive Not Ready" error.
    I tought I'll be speaking by myself here, so THANKS againg for your answers...I will post an update of the status very soon.

  6. #6
    Join Date
    Jul 2016
    Country
    ROMANIA
    Posts
    14
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    2

    Default

    UPDATE
    So, the power suply drive is Bosch 038035, when starting the machine by pressing Feed ON button his green LED turned off and a red one lights on, the one that specifies DRIVES, ok, so in order to see if the card is not damaged I've pulled out the boards (drives) from all axis and powered up the machine, the green LED stayed LIT, victory, power suply board is OK, then i've turned off the machine and i've inserted ONE drive card at a time. I've pulled in X axis drive card and powered on the machine, the red LED lights...
    Turned off the machine, pulled out X drive card and insert the Y drive card only, powered up the machine and...VICTORY, green LED stayed ON and no sign of red one, and I was able to even traverse the reference point for Y axis by pressing the +Y button . yey!! Then I've repeted the procedure with the same drive card but on X axis slot and on the Z axis slot and it worked, green LED stayed lit and I've been able to traverse reference point, only that on Z axis, the feed was maxim, so there is another problem to fix, anyway, the result is that I have one axis drive card that works and two others that don't. Next step will be fixing those two cards that give the power suply card the red LED. I have to mention that the axis drive cards have their own green and red LED and when powered up only the green lights...but power suply card give me red.
    Anyway, I'll keep you posted, just wait my electronics guy to get back to the city.

  7. Likes BugRobotics liked this post
  8. #7
    Join Date
    Jun 2015
    Country
    UNITED STATES
    State/Province
    Colorado
    Posts
    377
    Post Thanks / Like
    Likes (Given)
    861
    Likes (Received)
    143

    Default

    Glad to see your making progress. Please keep us updated on the issues and fixes. Good luck!

  9. #8
    Join Date
    Jul 2016
    Country
    ROMANIA
    Posts
    14
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    2

    Default

    Update2
    Hello guys! My electronics friend was able to come and make some further tests...during those we found that the 2nd board that come in pair with the drive, one is with integrated circuits (drive) and the other one is with transistors BUX48, so we find outh that the X axis slot for the board is burning the transistors and further on we recive red LED from powersuply card Bosch 038035. he was able to replace the damaged transistors and now I can move 2 axis of the 3. During the combinations of drive boards and transistors we find that one drive board is not working at all so we need to replace or repair it.
    His oppinion is that a motor is to blame for damageing the transistors, it demands a higher courent consumption and it burns the transistors...we'll need to make more measurements. Hopefully I will catch my friend in a day when he will have more time to spent on my machine.
    I will keep you posted with further results!

  10. Likes BugRobotics liked this post

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •