Fanuc 3m display questions
Close
Login to Your Account
Likes Likes:  0
Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2009
    Location
    N.E. Pa.
    Posts
    114
    Post Thanks / Like
    Likes (Given)
    7
    Likes (Received)
    4

    Default Fanuc 3m display questions

    Is there a way to get either the absolute or relative displays to show the correct z position for the current tool I am using? It only shows a large negative number in z while the tool is cutting the part. The x and y positions are correct. I use G92 for my work offset in x and y and G43 in the program to call tool offsets from the tool table.
    Thanks, Dan.

  2. #2
    Join Date
    Jan 2009
    Location
    Aurora, CO
    Posts
    87
    Post Thanks / Like
    Likes (Given)
    41
    Likes (Received)
    12

    Default

    Quote Originally Posted by camaro_dan67 View Post
    Is there a way to get either the absolute or relative displays to show the correct z position for the current tool I am using? It only shows a large negative number in z while the tool is cutting the part. The x and y positions are correct. I use G92 for my work offset in x and y and G43 in the program to call tool offsets from the tool table.
    Thanks, Dan.
    I have a Fanuc 3T (lathe) but think you would touch off the tool to the top of the part and then enter G50 Z0

  3. #3
    Join Date
    Sep 2005
    Location
    Oakland, CA
    Posts
    2,773
    Post Thanks / Like
    Likes (Given)
    446
    Likes (Received)
    818

    Default

    OP is not using the G50 position preset for the Z axis. He is using the Z offset for the tool stored in the offset table.Pretty sure there is a parameter that will change the display position. I know there is a setting on a 10M to do that. If you have the control manual, dig thru the parameters or perhaps someone will chime in here.

  4. #4
    Join Date
    Jan 2014
    Country
    UNITED STATES
    State/Province
    Washington
    Posts
    5,417
    Post Thanks / Like
    Likes (Given)
    977
    Likes (Received)
    3010

    Default

    No access to a series 3 controlled machine to try this, but parameter 4 bit 2 set to 1 may do what you want. It talks about displaying the programmed position when set to 1 versus the actual position when set to 0.

  5. #5
    Join Date
    Dec 2009
    Location
    N.E. Pa.
    Posts
    114
    Post Thanks / Like
    Likes (Given)
    7
    Likes (Received)
    4

    Default

    Thanks for the replies guys. Van I actually talked to the Fanuc service guy and he told me parameter 5 bit 2 which didn't work. I'll try your suggestion next. I do have the programming and service manuals for the control but alot of the wording in them is confusing.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •