Please Help Me Test My Renishaw Probe System
Close
Login to Your Account
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2003
    Location
    UK
    Posts
    869
    Post Thanks / Like
    Likes (Given)
    464
    Likes (Received)
    435

    Default Please Help Me Test My Renishaw Probe System

    I have a CNC lathe (Beaver TC20) that was retrofitted with a Renishaw Optical Probing system - (that is it optically connected - the actual probe is mechanical).

    When I bought the lathe the Renishaw LT02 optical probe head and LP2 sensor head had been sold off separately, but the Optical receiver head (OMM) and Machine Interface (MI12) remained.

    I bought an LT02S head with LP2 sensor but could get no response from it (Renishaw assured me that the LT02S would work with the OMM) - thinking I'd been sold a pup I got an LT02 with LP2 but get the same symptoms.

    I know that the actual sensors (The LP2's ) work, as I can test them with a meter, and when deflected they change state.

    I know that the OMM is sending SOMETHING out, as it's yellow light flashes, and a little optical detector that I cobbled together responds to the OMM's out going signals.

    When either the LT02S or the LT02 are in range and triggered I get no indication on either the OMM (which has a green 'signal' LED) or on the LT02s or LT02, both of which seem to have an indicator (touch indicator?) as they have thee devices behind their optical windows, a square one that I assume to be a receiver chip, and two other 'led shaped' blue devices - are these both transmitters or is one a touch indicator? The MI12 unit never shows 'probe status' changing.

    Now all this testing is being done with no controller programming - the MI12 unit is supplying power to the OMM, and the OMM yellow LED is flashing away in time with my (home made) detector seeing it. The MI12 unit is showing 'error' which the Renishaw pamphlet says could be device out of range (it isn't)

    Ideally I'd like to communicate with someone who has this system and compare note - even better would be to find someone locally that I could take my LT02S/LT02 to to see if they worked but that's sadly highly unlikely to be possible

    So absolutely ANY help would be much appreciated
    Attached Thumbnails Attached Thumbnails renishaw-lt02-optical-probe.jpg   renisha-omm-optical-receiver.jpg   renishaw-lt02s-optical-probe.jpg   renishaw-mi12-machine-interface.jpg  

  2. #2
    Join Date
    Sep 2018
    Country
    UNITED KINGDOM
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    I had a quick look at the serial number for the OMM but its an early model. It could be that the OMM is an OMMR failing that something either is not wired correctly or broken. IG's are available on renishaw.com, unfortunately the probe and interface system is obsolete and spares are not available. Legacy interfaces and transmission units


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •