Trouble with spindle bogging down under normal load
Close
Login to Your Account
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default Trouble with spindle bogging down under normal load

    I'm new to the forum but I have been using all the great info found here for quite some time. I'm having trouble with a Kia skt 25 lathe. The spindle has started slowing significantly under a normal load such as say drilling a hole at 1.875 diameter. Checked the belts for tightness and the belts were sufficiently tight although quite dirty. Cleaned the belts with some improvement. It seems as though when the machine has been running a couple hours this problem slowly goes away. Does anyone have any suggestions on what i should look for to find the root cause of this issue? Our shop is still using spade drills by the way. Drill running at 400 rpm with .012 feed per rev in 1018. Drilled 1000s of holes on this lathe with no problem until this past week.

  2. #2
    Join Date
    Jan 2012
    Location
    Savannah, Georgia, USA
    Posts
    1,655
    Post Thanks / Like
    Likes (Given)
    2625
    Likes (Received)
    630

    Default

    Does load meter rise or just slow as if something is ipping?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •