Anyone still running CharD10?
Close
Login to Your Account
Likes Likes:  0
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2002
    Location
    Regina, Canada
    Posts
    2,417
    Post Thanks / Like
    Likes (Given)
    5
    Likes (Received)
    84

    Default Anyone still running CharD10?

    if there is any interest I will post my long tale of woe. If not I have the scrappers number on speed dial.
    Bob

  2. #2
    Join Date
    Aug 2007
    Location
    Illinois USA
    Posts
    67
    Post Thanks / Like
    Likes (Given)
    1
    Likes (Received)
    0

    Default

    Quote Originally Posted by bob View Post
    if there is any interest I will post my long tale of woe. If not I have the scrappers number on speed dial.
    Bob
    I still service at least 8 of these D10 machines...


    Sent from my SM-G935P using Tapatalk

  3. #3
    Join Date
    Aug 2002
    Location
    Regina, Canada
    Posts
    2,417
    Post Thanks / Like
    Likes (Given)
    5
    Likes (Received)
    84

    Default

    Without going into the whole story I wound up with a D10 when my partner died. Mike always ran the machines for the little work we had for them I never paid much attention. Machine sat around for a year or so. Had time set it up and got it going. It was cutting very fast but terrible surface. I changed some settings got it going think showing 15 amps. Walked away couple minutes smoke from the cabinet resistors were very hot blew all the fuses on back and front top fan failed. Replaced fan and fuses set at 1/4 tried again blew some fuses. At 1/8 it sparks but will not cut just builds up a spike of carbon. Tried a bunch of stuff no luck. Any ideas?
    Bob


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •