Brother hs-300 blank error message?
Close
Login to Your Account
Results 1 to 11 of 11
  1. #1
    Join Date
    Jul 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    2
    Likes (Received)
    0

    Default Brother hs-300 blank error message?

    We recently had our brother hs-300 edm machine fixed, and are unable to use it. The error light on the control panel is lit up, and the diagnostics tab is not helpful. It says the the error is error #8, which is blank and the manual gives no information on what this means. The machine will not work at all until this is fixed. Has anyone else had this problem or know anyone we can contact that has any information?

  2. #2
    Join Date
    Aug 2010
    Location
    New England
    Posts
    254
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    31

    Default

    this may be incredibly obvious but it doesn't sound like it was fixed. have you talked to the repair person?

  3. #3
    Join Date
    Jul 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    2
    Likes (Received)
    0

    Default

    The EDM department of the Brother company has been disbanded, and there isn't an EDM repair company in our area, thus our department is working on it. We are working closely with the person who fixed it initially so that is not an issue. We are mostly concerned with what the error message could mean considering it is blank and the manual gives no other information. Thank you for responding.

  4. #4
    Join Date
    Aug 2010
    Location
    New England
    Posts
    254
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    31

    Default

    let me see what i can do. i have a few friends who still have brothers.

  5. #5
    Join Date
    Aug 2010
    Location
    New England
    Posts
    254
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    31

    Default

    this is wire EDM yes?

  6. #6
    Join Date
    Jul 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    2
    Likes (Received)
    0

    Default

    Yes it is!

  7. #7
    Join Date
    Jan 2011
    Location
    South Florida
    Posts
    624
    Post Thanks / Like
    Likes (Given)
    64
    Likes (Received)
    118

    Default

    You need to start from the beginning. What was being repaired on the machine? What was disassembled to do the repairs? Was it moved or removed from power? Could there be a phasing error? Go step by step.

    My machine also shows nothing for error #8, and I have been through my manuals and found nothing. So take us through the whole story.

    Mike

  8. #8
    Join Date
    Jan 2011
    Location
    South Florida
    Posts
    624
    Post Thanks / Like
    Likes (Given)
    64
    Likes (Received)
    118

    Default

    I just talked to the man I bought my HS-300 from many years ago. He is not a repairman but knows a lot about them and has many parts for them. He also did not know what that error is, but said if the machine had been apart and such that it probably needed the memory for the machine reset. He could not remember for sure the exact procedure, but said it was something like hitting the start button and holding it while you hit the Y+, Y-, X+, X- or something and then releasing the start button first.

    It totally resets the machine and you will loose programs, RAM and if equipped with it ball screw comp. Just puts it like new.

    He said it was in the manual, but I have been unable to find it.

    Hope this helps and maybe someone else has experience with it.


    Mike

  9. Likes mollieosborn liked this post
  10. #9
    Join Date
    Aug 2010
    Location
    New England
    Posts
    254
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    31

    Default

    this message on the 50 and the 70 machines indicate a ROM error. Reseat computer boards and replug connections.

  11. Likes mollieosborn liked this post
  12. #10
    Join Date
    Jul 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    2
    Likes (Received)
    0

    Default

    Sorry for the late response! This is a direct quote from the person in our department who has worked on/ fixed the machine: "Difficulties with Brother HS-300 EDM. The system went down from lack of water in the reservoir tank. System was ran without water and gilded the Impellor. Waited over 3 months for pump to be fixed. The Pump was then installed back on the system and powered on to find a battery error. By opening the enclosure 3 AA batteries were changed out. We currently have this error Line 8 with an *. We cannot pump water in the tank, Jog, Etc . Nothing happens. " We had to get the new pump from Japan I believe and then he installed it. Here is what our diagnostics screen looks like:brotheredm.jpg

  13. #11
    Join Date
    Jul 2019
    Country
    UNITED STATES
    State/Province
    Alabama
    Posts
    5
    Post Thanks / Like
    Likes (Given)
    2
    Likes (Received)
    0

    Default

    Thank you, we will look into this!


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •