Looking some answers about DK77 SF-L70.
Close
Login to Your Account
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2020
    Country
    BELARUS
    Posts
    1
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Question Looking some answers about DK77 SF-L70.

    Hello! I bought an edm machine cheaply. Neighboring enterprise went bankrupt. And new owners (I think they aren't very smart) decided to dispose dk77 sf-l70. It wasn't in working condition and there was no emulsion supply system. I decided to restore it myself. Yes, now the machine is working. But results don't please me. I am not an expert in EDM, so I don't understand some of features in work of my machine. The surface of cutt of part is very rough, and sometimes for some reason instead of the part periodically it cuts the upper current lead. I would be grateful if someone directed me on the right way. This is essentially my first experience with EDM.

  2. #2
    Join Date
    Aug 2016
    Country
    UNITED STATES
    State/Province
    Ohio
    Posts
    61
    Post Thanks / Like
    Likes (Given)
    1
    Likes (Received)
    15

    Default

    I believe your amperage is too high for the burn.
    Higher amps = faster burn times with worse finish.
    10 amps per 1 sq/in of electrode interface if burning graphite/steel.

    Cutting the upper lead could be a result of arcing.
    This could also be a result of too much amperage and too fast of servo.


    Jay Crumb


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •