Mits 110SZ - Servo drive repair?
Close
Login to Your Account
Likes Likes:  0
Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2004
    Location
    Wiggins CO. USA
    Posts
    1,361
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    58

    Default Mits 110SZ - Servo drive repair?

    Have a '92 Mits DWC110-SZ that best I can tell, has a bad X/Y servo drive. Started with being sluggish/pulsing speed when positioning, then started giving an alarm at power up and would take a few power cycles before it would come up without an error and allow the "ready" button to activate. Now it shows no alarm (on maint-alarm screen or the alarm light on the panel) but when the ready key is pressed it makes noise like it came to ready and then back out - but the ready light never lights.

    So, I guess Im at the point of looking into a repair place to get a price estimate, used drive, or bailing on the machine and selling as parts.

    Any recommendations on repair places? Leads on a good used servo drive? Thoughts?

    I have the FX10 running (new to me as of beginning of May), so Im not dead in the water, but would sort of like to have the SZ running if I can afford/justify it since its all fixtured up and so forth.

    Wade

  2. #2
    Join Date
    Jan 2011
    Location
    South Florida
    Posts
    620
    Post Thanks / Like
    Likes (Given)
    64
    Likes (Received)
    118

    Default

    This place is great!

    Zaritron

  3. #3
    Join Date
    Nov 2011
    Location
    CANADA
    Posts
    570
    Post Thanks / Like
    Likes (Given)
    40
    Likes (Received)
    175

    Default

    Try eBay. Always tons of parts for older machines like that.

    I've been luck a few times finding boards for my older Mits sinker.

  4. #4
    Join Date
    Jul 2004
    Location
    Wiggins CO. USA
    Posts
    1,361
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    58

    Default

    Quote Originally Posted by SteveEx30 View Post
    Try eBay. Always tons of parts for older machines like that.

    I've been luck a few times finding boards for my older Mits sinker.
    Yeah, been scanning for a spare drive for quite a while... Have yet to find one. Find a lot of SZ parts but yet to find a servo drive. And of course the parts machine I got back years ago - didnt have the monitor or servo drives - they were the first things sold from it before I found it.

    Maybe something will come up...

    Thanks!
    Wade

  5. #5
    Join Date
    Nov 2011
    Location
    CANADA
    Posts
    570
    Post Thanks / Like
    Likes (Given)
    40
    Likes (Received)
    175

    Default

    Start with the obvious and make sure all the wire harness are secure. I had a loose connector once give me amp errors. Can you visually see any caps that look bad ? Where are you located?

  6. #6
    Join Date
    Jul 2004
    Location
    Wiggins CO. USA
    Posts
    1,361
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    58

    Default

    Ive looked over everything and wiggled connectors etc.... havent found anything suspect. But will pull and re-seat connectors for grins and certainty. I didnt see any caps that looked bad but havent really delved into the inspection there with a flashlight etc - but will.

    Im in Colorado
    Wade

  7. #7
    Join Date
    Jul 2004
    Location
    Wiggins CO. USA
    Posts
    1,361
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    58

    Default

    Checked all connections today and searched as best I could for any bad caps but didnt see any... though with the drive still mounted its hard to see much other than the top board.

    Anyway, no difference... Still acts the same.

    Called Zaritron and emailed pictures as per his request - but he is gone for the week, so wont hear anything back til next week Id imagine.

    Wade


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •