Hard to start, rough running LPG forklift
Close
Login to Your Account
Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2004
    Location
    Southeast Michigan
    Posts
    6,559
    Post Thanks / Like
    Likes (Given)
    241
    Likes (Received)
    1459

    Default Hard to start, rough running LPG forklift

    Nissan LPG forklift.

    Either starts really hard, or doesn't start...then idles really rough.

    I've never really worked on anything LPG powered...if it was gas I would have already cleaned the carb and rebuilt it.

    LPG I'm clueless.

    Is the regulator/carb assembly something that can be disassembled/cleaned safely, or just rebuilt/replaced by a qualified technician with special tools?

    One of the times I disconnected the LPG line, it had water in it. Either water, or something that had no petroleum smell/feel to it.

    Any advice?

  2. #2
    Join Date
    Feb 2013
    Country
    UNITED STATES
    State/Province
    North Carolina
    Posts
    409
    Post Thanks / Like
    Likes (Given)
    506
    Likes (Received)
    153

    Default

    I had a similar problem with an Allis-Chalmers.
    In this case it related to the distributor -- coil, points, rotor.

  3. #3
    Join Date
    Jul 2008
    Location
    Philadelphia
    Posts
    1,948
    Post Thanks / Like
    Likes (Given)
    515
    Likes (Received)
    445

    Default

    Have you changed the tank? I have had one or two that where foul.
    I would not re-build the carbs. Just buy new ones>.

    Good Luck

  4. #4
    Join Date
    Oct 2009
    Location
    Oregon
    Posts
    4,183
    Post Thanks / Like
    Likes (Given)
    4487
    Likes (Received)
    2124

    Default

    There are a few different types of propane systems. Most difference is how they turn on/off. All can be rebuilt. Usually they are just gummed up with goo.

    Follow the propane hose and write down the model numbers of all the parts then look them up.

    troubleshooting is different depending on what system you have.

    My Komatsu has a Nissan engine and uses a vacuum signal to start and stop the vaporizer.

  5. #5
    Join Date
    Jun 2013
    Location
    Northern Il
    Posts
    1,306
    Post Thanks / Like
    Likes (Given)
    680
    Likes (Received)
    1223

    Default

    The carb and regulator/vaporizer are not very complicated. Actually the carb is actually more of a flow sensor that generates a vacuum signal to the regulator to modulate the pressure for proper air fuel mixture.

    You never said but is the engine running rich or lean when it is idling. LPG has a particular odor with some sooty smoke when rich and not much of an odor when lean. If the mixture is rich, you might have a sticky or leaking regulator/vaporizer needle valve.

    If you are running lean at idle, you might have a bad vacuum hose between the car and the regulator. This is an easy and cheap fix.

    The carbs and regulators are relatively cheap, so if you need to repair the carb and/or the regulator/vaporizer a kit might not be the least cost or best approach considering your experience and that you are asking for advice here.

  6. #6
    Join Date
    Feb 2011
    Location
    BFE Nevada/San Marcos Tx
    Posts
    1,142
    Post Thanks / Like
    Likes (Given)
    1013
    Likes (Received)
    595

    Default

    I was having hard start/ no start issues with my Daewoo lift earlier in year, problem turned out being an oil pressure switch. When cranking engine, the solenoid valve that allows propane to flow does not get electricity until oil pressure switch is activated. No idea if all lifts are wired this way.

  7. #7
    Join Date
    Jun 2013
    Location
    Northern Il
    Posts
    1,306
    Post Thanks / Like
    Likes (Given)
    680
    Likes (Received)
    1223

    Default

    Quote Originally Posted by dalmatiangirl61 View Post
    I was having hard start/ no start issues with my Daewoo lift earlier in year, problem turned out being an oil pressure switch. When cranking engine, the solenoid valve that allows propane to flow does not get electricity until oil pressure switch is activated. No idea if all lifts are wired this way.
    Good point. Some are wired so that the solenoid valve also opens when in start. When in ignition mode, the oil pressure switch will be in series to the solenoid valve. Bad wiring or switch will cause no start/lean start issues.

  8. #8
    Join Date
    Aug 2012
    Location
    California, Central Coast
    Posts
    3,529
    Post Thanks / Like
    Likes (Given)
    2187
    Likes (Received)
    1366

    Default

    The propane regulator/vaporizer could be gunked up with tar. They usually have a plug that can be removed to clean it out. Do it with the engine hot so the tar is soft.
    These devices use radiator coolant to warm up the liquid propane, maybe there is a leak in yours and that is where the water you saw came from?

  9. #9
    Join Date
    Jul 2004
    Location
    Southeast Michigan
    Posts
    6,559
    Post Thanks / Like
    Likes (Given)
    241
    Likes (Received)
    1459

    Default

    I am pretty sure it's ignition related...I left the seat up on it yesterday after looking at vacuum lines. It poured a bit, and now it won't start at all. And the more I think back, the hardest days have been when it's either humid or just rained...when it's been dry, I don't get a lot of problems.

    So, I'll replace the cap and rotor and see how it does.

    It's been a while since I've worked on anything with carburetor / manual ignition any bigger than the lawnmower.

  10. Likes Ox liked this post

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •