MAZAK QT8 T Plus Help!!!!
Close
Login to Your Account
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2019
    Country
    UNITED STATES
    State/Province
    New York
    Posts
    1
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default MAZAK QT8 T Plus Help!!!!

    Hello. I have a QT8 with a T plus color control with graphics.

    I don't use the machine often, (it has under 1000 hours on it since new in 1998) but for a while now, I had to turn it off and on a few times before it would "catch" and power up. It's getting harder and harder to get it to start. Here's what happens....

    I turn the main power on, and all the fans run normal. Then when I push the control power on switch, it takes a few seconds and I get an empty white framed box on the bottom right side of the screen, and the only other lights I get are the line of red zero's for spindle and feed. The hydraulic pumps don't come up or anything.

    Usually, if I turn it off and then back on a few times it will start, but I can't be sure it will start at the moment I need it. Sometimes it takes me a couple hours of trying, and letting it rest, then trying, and letting it rest before it will finally power up. mybkexperience

    If there's anyone out there that really knows Mazak, can you please help me get this solved so I can count on my machine again?
    Last edited by James394; 11-09-2019 at 11:13 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    Rochester, NY USA
    Posts
    2,171
    Post Thanks / Like
    Likes (Given)
    10
    Likes (Received)
    507

    Default

    The spindle amp should be a FR-SF.
    The module at the top is the power supply.
    When working, there should be an LED that is visible inside.
    If it is off when not working, insure that you have all 3 phases of power to the FR-SF.
    If the power is good, I would replace the power supply first.

    Bill

  3. #3
    Join Date
    Sep 2006
    Location
    Abingdon, VA
    Posts
    3,353
    Post Thanks / Like
    Likes (Given)
    4486
    Likes (Received)
    3101

    Default MAZAK QT8 T Plus Help!!!!

    The T-Plus control has the MDS drives, so no FR-SF spindle drive.

    It is possibly your 24v power supply (sometimes two)--- a little black box that takes 100v ac and converts it into 24v dc. This 24v circuit is critical, without it the machine will not power up completely. So, check this first.

    Next is the NC power supply board, which is the QX084. If your 24v power supply is working correctly, then it very well could be the QX084. You can have it rebuilt, or source a spare on Ebay. It has a series of LED lights that should be green when it is on.

    Good luck with it,

    ToolCat
    Last edited by cnctoolcat; 11-11-2019 at 04:40 PM.

  4. Likes benganboll liked this post
  5. #4
    Join Date
    Feb 2013
    Location
    ny
    Posts
    60
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    6

    Default

    Quote Originally Posted by James394 View Post
    lights I get are the line of red zero's for spindle and feed

    having been through this over last couple weeks, for me, if i got the red zeros that means that the qx084 nc power supply is working, i would put money on the 24v power supplies (in blue circle)

    ps.jpg

  6. Likes cnctoolcat liked this post

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •