monarch 10ee 1961 need schematic serial44892 manufacture date 4-61. - Page 2
Close
Login to Your Account
Page 2 of 2 FirstFirst 12
Results 21 to 32 of 32
  1. #21
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    the tech at Monarch said it is usually a problem with diodes in the module box

    Rec3 must be in the module box. anybody ever repair those diodes?

  2. #22
    Join Date
    Mar 2016
    Country
    UNITED STATES
    State/Province
    Louisiana
    Posts
    437
    Post Thanks / Like
    Likes (Given)
    220
    Likes (Received)
    79

    Default

    Quote Originally Posted by lectrician1 View Post
    the tech at Monarch said it is usually a problem with diodes in the module box

    Rec3 must be in the module box. anybody ever repair those diodes?
    Nope you replace them there are threads here that deal with there replacement.

  3. #23
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    i did find two bad diodes in the module.i ordered them.be here in a few days
    I'll keep you posted.

  4. Likes TheOldCar, labeeman liked this post
  5. #24
    Join Date
    Mar 2016
    Country
    UNITED STATES
    State/Province
    Louisiana
    Posts
    437
    Post Thanks / Like
    Likes (Given)
    220
    Likes (Received)
    79

    Default

    Quote Originally Posted by lectrician1 View Post
    i did find two bad diodes in the module.i ordered them.be here in a few days
    I'll keep you posted.
    Hope you ordered some 3 amp fuses also.

  6. #25
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    three 3amp fuses on the way. i'll prolly throw a glass fuse in there just to test it after i install the diodes. glass fuses are cheap.

  7. #26
    Join Date
    Sep 2002
    Location
    Salinas, CA USA
    Posts
    4,151
    Post Thanks / Like
    Likes (Given)
    266
    Likes (Received)
    232

    Default

    Quote Originally Posted by lectrician1 View Post
    i did find two bad diodes in the module.i ordered them.be here in a few days
    I'll keep you posted.
    Don't waste $$ buying diodes from Monarch. You can buy equivalents on Ebay for cheap, there are lots of threads about it. I have lots of extras if you need some.

  8. #27
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    bought a dozen 600v 3amp diodes for $.99 plus $3.44 shipping ebay from california.

  9. #28
    Join Date
    Sep 2016
    Country
    UNITED STATES
    State/Province
    California
    Posts
    105
    Post Thanks / Like
    Likes (Given)
    19
    Likes (Received)
    10

    Default

    It looks like your lathe was built right after mine. When I get the lathe later in two weeks I can take any pictures of the internals if that helps. Serial number 44891

  10. #29
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    i got the schematics directly from monarch thanks

  11. #30
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    ok i put the new diodes in rec 3 in the module and a new 3 amp fuse
    we have some progress.
    i turn power on. wait a minute for the green light. press the start button.
    the contactor pulls in and stays in.
    the c3j thyratron lights up.
    the c16 js do not light up
    i move the drum switch to forward and the forward contactor pulls in. the c3j goes slightly dim and the spindle doesnt move
    same thing for reverse.
    what is the next thing to check?
    thanks everyone for your help
    Rich

  12. #31
    Join Date
    Mar 2016
    Country
    UNITED STATES
    State/Province
    Louisiana
    Posts
    437
    Post Thanks / Like
    Likes (Given)
    220
    Likes (Received)
    79

    Default

    You need to try a known good pair of the big tubes

  13. #32
    Join Date
    Mar 2012
    Location
    Las Vegas
    Posts
    699
    Post Thanks / Like
    Likes (Given)
    12
    Likes (Received)
    69

    Default

    i just ordered a set of replacements thyratron from scissio controls


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •