Having a little trouble with X & C milling, LB300M
Close
Login to Your Account
Likes Likes:  0
Results 1 to 1 of 1
  1. #1
    Join Date
    Dec 2010
    Location
    PA
    Posts
    640
    Post Thanks / Like
    Likes (Given)
    177
    Likes (Received)
    167

    Default Having a little trouble with X & C milling, LB300M

    So, I want to ball mill on the face of my part. It's a large radius, these bungs go on the side of a pipe and get welded on.

    The plan is mill using x and c, have the machine calculate its own "Y" and Z points, mill across in x, rapid to the same "Y" on the negative side, cut back, rapid back to "Y" positive location and recalc points, etc.

    Here's my code-

    G00 X20 Z5
    G50 S1200
    NAT03
    M110 (C AXIS JOINT)
    G94 M146 M15 M08 (M146 = C AXIS UNCLAMP, G94 = FPM)
    G00 X 4. Z-2.63 T030303 SB=604 M13 M153
    V1=1.875
    N100
    V2=3.3125 (RADIUS LEFT ON PART)
    V3=[SQRT[[V2*V2]-V1*V1]]
    V4=[1.875+.375] (PART RAD + CLEARANCE)
    G17
    G137 C0 (Y AXIS MODE ON)
    G00 X[V4] Y[V1] Z-[V3]
    G101 X-[V4] F50.00
    G0 Y-[V1]
    G101 X[V4]
    G0Y[V1]
    V1=V1-.03
    IF [V1 GE .01] GOTO N100
    G136 (Y AXIS MODE OFF)
    G95 M12 M09 (MACHINE SPINDLE STOP)
    M109 (CANCEL M110 C AXIS JOINT)
    G00 X20 Z25 T0100
    M02

    While it does run, and it does do what I want, the X location doesn't jive with what I have programmed. V4 on the parameter page shows V4 is set at 2.25 which is correct. When the program runs it starts cutting at X5.8576. I have nothing in the tool radius or tip direction for this milling cutter.

    I figured i'd comp the radius of the ball mill myself to eliminate potential trouble.

    This is the first time I've done a macro program on this machine, and also the first one i've done in probably 10 years.

    Anyone have any ideas what's up?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •