Simultaneous Rotary and Linear Axis Feedrate (deg/min at least in most of the cases)
Close
Login to Your Account
Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2018
    Country
    HUNGARY
    Posts
    1
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default Simultaneous Rotary and Linear Axis Feedrate (deg/min at least in most of the cases)

    Machines known for this problem:
    Okuma LB3000 EX II-MY C950
    Okuma LB3000 EX II M C1000 with SMW SLUX-2 snug on steady rest
    Okuma Genos M560R-V with Tsudakoma RNA 200R (A-axis rotary table)
    Okuma Genos M560-V-E with Tsudakoma RNA 200R (A-axis rotary table)

    As the manual describes: When interpolating one or more linear axis simultaneously with a rotary axis be it C or A for lathe or machining center , the feedrate must be input in the unit of degrees/minute. As it turns out, in some radical situations when the angular movement is very small like 0,01 degrees and the linear movement is fairly large like 2 mm (and thus thus the angular feedrate has to be pretty low) the control differ from the above described behaviour , instead it interprets and carries out the input feedrate in a mm/minute fashion so the driving factor to the feedrate is the linear axis velocity and the rotation feedrate follows that motion. In these cases the actual tool feedrate is
    magnitude lower than the desired one.

    Now I'm pretty sure that this phenomena originates from a mathematical/physical limitation of the machines axis control system/motor encoder division numbers.
    And here we are closing on my main problem that may fancy the minds of some of us who like to learn each day.
    In an ideal world the proper solution for the problem is Inverse Time Feedrate command.
    As it looks like today, there is no chance of getting that function in a short manner of time and i still have some parts that needs to be machined with the above mentioned machines.

    After I developed a macro in Edgecam to calculate the proper feedrate for the moves when I use rotary axis it turns out I get beautiful feedrate output, tested it in some ridiculously radical situations when really low angle and large axial movement crated an ultra small feedrate and the output is correct. I also make use of G119 on the lathes so i can input mm/minute feedrate for the circular interpolations and the motion is perfect in circles. but I don't have the G175 command on the machining centers and that makes the output always so grainy
    Anyway all thing works fine but I would really need to know what is exactly the threshold of the applicability of the angular feedrate in terms of relation to the simultaneously interpolated linear axes travel distance (wonder why I didn't us this sentence as the title ) so that I could test it in the post processing macro and output mm/min feedrate when needed.

    In the post to make my self sure in the debug part i made a calculation with the inverse time equation too and it gives the same values not to mention the manual paperform calculations which gave the same values.
    I encounter a limitation of machine control and that was clearly demostrated when I issued the same F0,1.. feedrate for linear + rotary axis move and only rotary axis move and the cutting time differed by orders of magnitude
    like 1 minute for a movement that moved 0,02deg and high linear distance (2-3mm) and ~ sub 1 seconds for the same 0,02 deg move when issued without any linear axis movement with the same 0,1 deg/min feedrate.

    Code:
    (numbers 1)
     G0 X59.92 Z-253.039 C174.732 M16
     G0 X58.92 Z-253.039
     G1 X57.12 Z-253.039 F50
     G1 X57.12 Z-248.361 C174.731 M16 F0.028  <---- this gets interpreted in mm/min fashion and carried out at unacceptably low feedrate
     G1 X57.12 Z-249.402 C172.66 M16 F252.4
     G0 X59.92 Z-249.402
     G0 X59.92 Z-245.039 C174.732 M15
     G0 X58.92 Z-245.039
     G1 X57.12 Z-245.039 F50
     G1 X57.12 Z-240.361 C174.731 M16 F0.028  <---- this gets interpreted in mm/min fashion and carried out at unacceptably low feedrate
     G1 X57.12 Z-241.402 C172.66 M16 F252.4
     G0 X59.92 Z-241.402
    Just to prove I'm not talking about the air I put up some pictures of the finished parts.
    img_20181206_195539.jpgimg_20181206_195457.jpgimg_20181206_195433.jpg


    I really Hope that someone have some good Idea on this
    Last edited by ungie; 12-07-2018 at 03:34 AM.

  2. #2
    Join Date
    Dec 2018
    Country
    NETHERLANDS
    Posts
    8
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    1

    Default

    definitely, there is something wrong with the machine


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
2