Converter identification
Close
Login to Your Account
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Join Date
    May 2016
    Country
    UNITED STATES
    State/Province
    Indiana
    Posts
    97
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    6

    Default Converter identification

    I recently acquired a used unit from a shop a friend of mine bought. He had no use for it so I removed it from the shop and brought it home. I built a converter a few years ago for my Bridgeport mill and know a little bit about how the work.

    I have a couple questions about the new converter I acquired. Comparing it to the one that I built and currently use, this one is missing some items and I canít understand how it would work I feel that I am missing something. My current unit has a contactor, timer, start capacitors and run capacitor etc.... But the newer unit that I just picked up only has what appear to be 4 50 mfd run capacitors. And it does not have any start up circuitry. It was sitting outside the building with only three wires coming out and hooked to it.

    Iím trying to figure out how to upload images on here to show what I have but I canít figure out how.

  2. #2
    Join Date
    Feb 2011
    Location
    BFE Nevada/San Marcos Tx
    Posts
    2,989
    Post Thanks / Like
    Likes (Given)
    3028
    Likes (Received)
    1898

    Default

    We will need pics to even hazard a guess. My Phase-A-Matic has no timers or contactors, just a big box of caps, maybe that is what you have?

    For pics go to "Advanced", scroll past the dialog box till you see "Manage Attachments" click on it, then click on "add files", select pic then click on "Upload file", then click on "done". May or may not work for you on google chrome.

  3. #3
    Join Date
    May 2016
    Country
    UNITED STATES
    State/Province
    Indiana
    Posts
    97
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    6

    Default

    I am using safari for internet on my phone, and going under advanced does not bring up the manage attachments option. Not sure what to do lol.

  4. #4
    Join Date
    Dec 2019
    Country
    NEW ZEALAND
    Posts
    403
    Post Thanks / Like
    Likes (Given)
    27
    Likes (Received)
    91

    Default

    Upload to imgur or equivalent, post link here.

  5. #5
    Join Date
    Sep 2011
    Country
    UNITED STATES
    State/Province
    Virginia
    Posts
    20,086
    Post Thanks / Like
    Likes (Given)
    7561
    Likes (Received)
    11969

    Default

    Quote Originally Posted by Billyboyr66 View Post
    only has what appear to be 4 50 mfd run capacitors. And it does not have any start up circuitry. It was sitting outside the building with only three wires coming out and hooked to it.
    May not even BE a "converter", then.

    Even so, if the caps are old? Could was all you REALLY have is a BOX!


  6. #6
    Join Date
    Feb 2011
    Location
    BFE Nevada/San Marcos Tx
    Posts
    2,989
    Post Thanks / Like
    Likes (Given)
    3028
    Likes (Received)
    1898

    Default

    Quote Originally Posted by Billyboyr66 View Post
    I am using safari for internet on my phone, and going under advanced does not bring up the manage attachments option. Not sure what to do lol.
    Get a real computer, use firefox.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •