Dangers of Working with Inverters?
Close
Login to Your Account
Results 1 to 17 of 17
  1. #1
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    Rhode Island
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Question Dangers of Working with Inverters?

    Hey All,
    I have a 1992 Fadal VMC40 with the mitsubishi Freqrol Z300 Model Z320-7.5k-UL. I often get a spindle fault upon starting the machine, but when I let it warm up and sit for half an hour or so it works no problem. I figured it was the inverted because I was getting an alarm on it and would have to reset.

    Today, the inverter just started smoking.

    I assume I'll have to replace it, but I'd like to take a look and see if there's something obvious that I or someone substantially more qualified could repair.

    My question is this: What are the dangers of working on inverters that have previously been under power? I'll identify the capacitors and discharge them. Is that the only risk? Anyone have experience with these inverters in particular? Or have an idea of what might be going wrong?

    Thanks as always.

  2. #2
    Join Date
    Jul 2009
    Location
    Peoria, IL
    Posts
    11,667
    Post Thanks / Like
    Likes (Given)
    50
    Likes (Received)
    8915

    Default

    Once the caps are discharged, it's pretty safe. Sounds like an IGBT module has shorted.

  3. Likes lumley32 liked this post
  4. #3
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    Rhode Island
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Unhappy

    Well, uh, I think I found the problem. The silver (aluminum) unit that mounts to the heat sink has...melted. Is this the IGBT module? Further input and advice always appreciated.

    inverter-pic.jpg

  5. #4
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    2,691
    Post Thanks / Like
    Likes (Given)
    194
    Likes (Received)
    1972

    Default

    Nah, they all look like that.......

    kidding..........


    pull the numbers off it and google it, some are discontinued, but there are guys who specialize in finding that type stuff

  6. #5
    Join Date
    Jan 2019
    Country
    UNITED STATES
    State/Province
    Rhode Island
    Posts
    18
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Looks like it's the brake resistor. Is this a regen circuit issue? I have no idea what I'm doing...

    brake-resistor-manual.jpg

  7. #6
    Join Date
    Oct 2012
    Location
    Pennsylvania
    Posts
    304
    Post Thanks / Like
    Likes (Given)
    122
    Likes (Received)
    137

    Default

    Quote Originally Posted by nineandtwothirds View Post
    Looks like it's the brake resistor. Is this a regen circuit issue? I have no idea what I'm doing...

    brake-resistor-manual.jpg
    Based on your pic, it's probably the brake resistor. You could try replacing that by itself, but something else in the drive may have went that caused the resistor to go.

    You may be able to disconnect it and try the drive. It may fault if it doesn't sense it. If that's the case, you should be able to change a parameter in the drive to disable the braking - unless it's controlled by the CNC.

    OR - a quick ebay search turned up a few of that model for $300 or so. It may be better to buy another unit than to put money into one that's already been smoked and overheated.

  8. #7
    Join Date
    Jul 2008
    Country
    UNITED STATES
    State/Province
    South Carolina
    Posts
    605
    Post Thanks / Like
    Likes (Given)
    194
    Likes (Received)
    355

    Default

    "Today, the inverter just started smoking."

    You realize gum and patches are available....

  9. Likes 4GSR, Rudd liked this post
  10. #8
    Join Date
    Jul 2009
    Location
    Peoria, IL
    Posts
    11,667
    Post Thanks / Like
    Likes (Given)
    50
    Likes (Received)
    8915

    Default

    Pretty common failure mode. The braking IGBT has likely shorted and dumped the DC bus voltage into the braking resistor continuously until something finally let go. This is so common that many machines have a thermistor on the braking resistor to shut down if the resistor gets too hot.

    Check all of the transistor modules. I think you will find one has a dead short.

  11. Likes Hightemp, motion guru, JST liked this post
  12. #9
    Join Date
    Sep 2002
    Location
    People's Republic
    Posts
    2,691
    Post Thanks / Like
    Likes (Given)
    194
    Likes (Received)
    1972

    Default

    Quote Originally Posted by Hodge View Post
    "Today, the inverter just started smoking."

    You realize gum and patches are available....
    Look, if you are going to post something, try to be useful

    Like, tell the guy what kind of gum you are suggesting, I mean, is it juicy fruit, sugarless

    People need to know

  13. Likes Hodge, tdmidget liked this post
  14. #10
    Join Date
    Oct 2010
    Location
    Dewees Texas
    Posts
    2,253
    Post Thanks / Like
    Likes (Given)
    26
    Likes (Received)
    591

    Default

    One thing to check is your incoming voltage. One of my invertor's braking resistor will get so hot you could fry eggs on it when the voltage gets over 248. 245 is OK, so a buck boost transformer dropped it to 236 as the power company was unwilling to adjust it this time.

  15. #11
    Join Date
    Jan 2006
    Location
    Angier, North Carolina
    Posts
    2,542
    Post Thanks / Like
    Likes (Given)
    1012
    Likes (Received)
    913

    Default

    Quote Originally Posted by nineandtwothirds View Post
    Well, uh, I think I found the problem. The silver (aluminum) unit that mounts to the heat sink has...melted. Is this the IGBT module? Further input and advice always appreciated.

    inverter-pic.jpg
    Not now, it isn't!


  16. #12
    Join Date
    Jul 2008
    Country
    UNITED STATES
    State/Province
    South Carolina
    Posts
    605
    Post Thanks / Like
    Likes (Given)
    194
    Likes (Received)
    355

    Default

    Quote Originally Posted by gustafson View Post
    Look, if you are going to post something, try to be useful

    Like, tell the guy what kind of gum you are suggesting, I mean, is it juicy fruit, sugarless

    People need to know
    My pardon, nicotine gum, of course

  17. Likes gustafson liked this post
  18. #13
    Join Date
    Sep 2011
    Country
    UNITED STATES
    State/Province
    Virginia
    Posts
    25,602
    Post Thanks / Like
    Likes (Given)
    7561
    Likes (Received)
    8047

    Default

    Quote Originally Posted by awake View Post
    Not now, it isn't!

    And this is why the nation has so much college debt?

    Usta bee we'd have just said:

    "Not no more, it ain't"

    ... and had money left for beer.

  19. #14
    Join Date
    Mar 2009
    Country
    UNITED STATES
    State/Province
    California
    Posts
    4,825
    Post Thanks / Like
    Likes (Given)
    89
    Likes (Received)
    892

    Default

    Quote Originally Posted by gustafson View Post
    Look, if you are going to post something, try to be useful

    Like, tell the guy what kind of gum you are suggesting, I mean, is it juicy fruit, sugarless

    People need to know
    Yeah, like the last one.

  20. #15
    Join Date
    Jun 2001
    Location
    St Louis
    Posts
    17,766
    Post Thanks / Like
    Likes (Given)
    1753
    Likes (Received)
    2946

    Default

    Quote Originally Posted by FredC View Post
    One thing to check is your incoming voltage. One of my invertor's braking resistor will get so hot you could fry eggs on it when the voltage gets over 248. 245 is OK, so a buck boost transformer dropped it to 236 as the power company was unwilling to adjust it this time.
    That, and while you are at it, check the trip point for the OV if you can. The "245 OK and 248 not OK" is typical of setting the OV point for the brake low enough that a "normal variation" of line voltage can trigger it.

    usually the trip voltage is settable. Setting too high can cause a shutdown trip if the "brake resistor" does not drain enough charge off the bus capacitors fast enough, so it may be set fairly low, and you may want to be careful with re-setting it.

    But, if the bus voltage is driven up by incoming line voltage, the brake resistor may be "on" at whatever its full allowable duty cycle is. If that is too much for the heatsinking it has, then you may burn it up, and in any case, all that you are doing is wasting power with no benefit, so a small increase in trip setting may fix it with no bad consequences. .

  21. #16
    Join Date
    Aug 2012
    Location
    California, Central Coast
    Posts
    3,038
    Post Thanks / Like
    Likes (Given)
    2111
    Likes (Received)
    1166

    Default

    Quote Originally Posted by gustafson View Post
    Look, if you are going to post something, try to be useful

    Like, tell the guy what kind of gum you are suggesting, I mean, is it juicy fruit, sugarless

    People need to know
    Everyone knows to chew and use Trident when working on three phase stuff, right?

  22. #17
    Join Date
    Sep 2011
    Country
    UNITED STATES
    State/Province
    Virginia
    Posts
    25,602
    Post Thanks / Like
    Likes (Given)
    7561
    Likes (Received)
    8047

    Default

    Quote Originally Posted by Rob F. View Post
    Everyone knows to chew and use Trident when working on three phase stuff, right?
    Chew. Use. That's only two.

    What's for the third leg? Try to balance it on yer glans?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •