Kbac-27D vfd help please: Overload status
Close
Login to Your Account
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2019
    Country
    UNITED STATES
    State/Province
    Michigan
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default Kbac-27D vfd help please: Overload status

    Today I received my new kbac-27d vfd. Upon plugging it in the status LED is solid red, which the user manual says is "overload", but theres no advice on how to fix the issue. Theres no load on the motor, shaft spins freely. Being new to vfd's I have not adjusted any trimpots yet, they are at the factory settings. I verified the jumpers match the motor/power (230v in, 2hp motor, 60hz). I unhooked the motor wires from the vfd and plugged the vfd in again...same thing...green power LED, solid red status LED.

    I'm not sure where to go from here and I'm finding no info with a net search. My income is dependent on getting this up and running so any help would be greatly appreciated!

  2. #2
    Join Date
    May 2019
    Country
    UNITED STATES
    State/Province
    Michigan
    Posts
    2
    Post Thanks / Like
    Likes (Given)
    0
    Likes (Received)
    0

    Default

    Ha, nevermind...I got it resolved. Ended up being a simple problem. The "start switch is a 3 position switch, and by default the LED is red. When switched to the up/start position the LED should turn green...saying you are good to go. My switch had a catch in it so when I went from the bottom most/stop setting to what I thought was start, it actually stopped at the mid point. I pushed a bit harder and it popped, and went fully up which allowed it to turn green. Maybe light casting flash in the switch, but everything is fine now.

    I would delete the thread but don't see the option.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •